summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-04 19:37:31 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-04 19:37:31 +0000
commit0f14a2a0e269bf1295c24954b76e74276424ddca (patch)
treedd97f1adecba443316fd287cd56c24c0701b30dd /dev-ruby
parentversion bump (diff)
downloadgentoo-2-0f14a2a0e269bf1295c24954b76e74276424ddca.tar.gz
gentoo-2-0f14a2a0e269bf1295c24954b76e74276424ddca.tar.bz2
gentoo-2-0f14a2a0e269bf1295c24954b76e74276424ddca.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/bundler/ChangeLog7
-rw-r--r--dev-ruby/bundler/bundler-1.0.7.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 980406f7c6fa..f0d56d9c25cd 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.6 2010/10/16 08:29:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.7 2010/12/04 19:37:31 graaff Exp $
+
+*bundler-1.0.7 (04 Dec 2010)
+
+ 04 Dec 2010; Hans de Graaff <graaff@gentoo.org> +bundler-1.0.7.ebuild:
+ Version bump.
*bundler-1.0.3 (16 Oct 2010)
diff --git a/dev-ruby/bundler/bundler-1.0.7.ebuild b/dev-ruby/bundler/bundler-1.0.7.ebuild
new file mode 100644
index 000000000000..72d528f702c5
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.0.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.7.ebuild,v 1.1 2010/12/04 19:37:31 graaff Exp $
+
+EAPI=2
+
+# ruby19 → uncountable number of test failures
+# jruby → needs to be tested because jruby-1.5.1 fails in multiple
+# ways unrelated to this package
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="http://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend dev-ruby/rubygems
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+RDEPEND="${RDEPEND}
+ dev-vcs/git"
+DEPEND="${DEPEND}
+ test? ( dev-vcs/git )"
+
+RUBY_PATCHES=( "${FILESDIR}"/${PN}-1.0.3-gentoo.patch )
+
+all_ruby_prepare() {
+ # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
+ sed -i -e '575s/should/should_not/' spec/runtime/setup_spec.rb || die
+
+ # Fails randomly and no clear cause can be found. Might be related
+ # to bug 346357. This was broken in previous releases without a
+ # failing spec, so patch out this spec for now since it is not a
+ # regression.
+ sed -i -e '49,54d' spec/install/deploy_spec.rb || die
+}