summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-02 20:52:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-10-02 20:52:19 +0000
commit0d0bc7365e4101577b9fe432863a8c79290f29b0 (patch)
tree1864751fe6b64f65c8a91c6328ec461a2c2e9f03 /dev-ruby
parentinherit user eclass (diff)
downloadgentoo-2-0d0bc7365e4101577b9fe432863a8c79290f29b0.tar.gz
gentoo-2-0d0bc7365e4101577b9fe432863a8c79290f29b0.tar.bz2
gentoo-2-0d0bc7365e4101577b9fe432863a8c79290f29b0.zip
Version bump, this includes my patch.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/aws-sdk/ChangeLog8
-rw-r--r--dev-ruby/aws-sdk/aws-sdk-1.6.8.ebuild (renamed from dev-ruby/aws-sdk/aws-sdk-1.6.7-r1.ebuild)11
-rw-r--r--dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch45
3 files changed, 9 insertions, 55 deletions
diff --git a/dev-ruby/aws-sdk/ChangeLog b/dev-ruby/aws-sdk/ChangeLog
index 624541940f44..e8010b6b32b6 100644
--- a/dev-ruby/aws-sdk/ChangeLog
+++ b/dev-ruby/aws-sdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/aws-sdk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/ChangeLog,v 1.12 2012/10/02 03:15:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/ChangeLog,v 1.13 2012/10/02 20:52:19 flameeyes Exp $
+
+*aws-sdk-1.6.8 (02 Oct 2012)
+
+ 02 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> +aws-sdk-1.6.8.ebuild,
+ -aws-sdk-1.6.7-r1.ebuild, -files/aws-sdk-1.6.7.patch:
+ Version bump, this includes my patch.
*aws-sdk-1.6.7-r1 (02 Oct 2012)
diff --git a/dev-ruby/aws-sdk/aws-sdk-1.6.7-r1.ebuild b/dev-ruby/aws-sdk/aws-sdk-1.6.8.ebuild
index 102ff50b10ab..5caeb8c62255 100644
--- a/dev-ruby/aws-sdk/aws-sdk-1.6.7-r1.ebuild
+++ b/dev-ruby/aws-sdk/aws-sdk-1.6.8.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.6.7-r1.ebuild,v 1.1 2012/10/02 03:15:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/aws-sdk/aws-sdk-1.6.8.ebuild,v 1.1 2012/10/02 20:52:19 flameeyes Exp $
EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.rdoc"
@@ -38,15 +38,8 @@ ruby_add_rdepend "virtual/ruby-ssl
RUBY_PATCHES=(
${PN}-1.5.3-disabletest.patch
- ${P}.patch
)
-all_ruby_compile() {
- if use doc; then
- rdoc || die
- fi
-}
-
each_ruby_install() {
sed -e "s:VERSION:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${RUBY_FAKEGEM_GEMSPEC}"
each_fakegem_install
diff --git a/dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch b/dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch
deleted file mode 100644
index cf304c39ab3c..000000000000
--- a/dev-ruby/aws-sdk/files/aws-sdk-1.6.7.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/lib/aws/core/option_grammar.rb b/lib/aws/core/option_grammar.rb
-index bb612bb..39d6464 100644
---- a/lib/aws/core/option_grammar.rb
-+++ b/lib/aws/core/option_grammar.rb
-@@ -11,7 +11,6 @@
- # ANY KIND, either express or implied. See the License for the specific
- # language governing permissions and limitations under the License.
-
--require 'base64'
- require 'bigdecimal'
- require 'json'
-
-@@ -112,11 +111,11 @@ module AWS
- end
-
- def encode_value(value)
-- Base64.strict_encode64(value.to_s)
-+ [value.to_s].pack("m0").gsub("\n", '')
- end
-
- def hash_format(value)
-- Base64.strict_encode64(value.to_s)
-+ [value.to_s].pack("m0").gsub("\n", '')
- end
-
- end
-diff --git a/spec/aws/s3/client_spec.rb b/spec/aws/s3/client_spec.rb
-index 6ac80e1..f39a4a4 100644
---- a/spec/aws/s3/client_spec.rb
-+++ b/spec/aws/s3/client_spec.rb
-@@ -247,8 +247,12 @@ module AWS
-
- request.http_method.should eq('PUT')
- request.querystring.should eq('tagging')
-- request.headers['content-md5'].should eq(client.send(:md5, xml))
-- request.body.should eq(xml)
-+
-+ # the array is differently sorted on Ruby 1.8
-+ unless RUBY_VERSION =~ /^1.8/
-+ request.headers['content-md5'].should eq(client.send(:md5, xml))
-+ request.body.should eq(xml)
-+ end
-
- end
-