summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-03-14 15:06:42 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-03-14 15:06:42 +0000
commit0b9edc2e91703f471a59b4342352d82221278024 (patch)
treec735b518d2c7adbdb21668685dd6aaa50678aa76 /dev-ruby
parentVersion bump from upstream. Due to filesystem layout changes, there WILL be a... (diff)
downloadgentoo-2-0b9edc2e91703f471a59b4342352d82221278024.tar.gz
gentoo-2-0b9edc2e91703f471a59b4342352d82221278024.tar.bz2
gentoo-2-0b9edc2e91703f471a59b4342352d82221278024.zip
Version bumped. Clean up.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/iobuffer/ChangeLog7
-rw-r--r--dev-ruby/iobuffer/iobuffer-1.1.2.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/iobuffer/ChangeLog b/dev-ruby/iobuffer/ChangeLog
index 5265043c26e9..2e28987d52c1 100644
--- a/dev-ruby/iobuffer/ChangeLog
+++ b/dev-ruby/iobuffer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/iobuffer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/iobuffer/ChangeLog,v 1.5 2012/01/13 07:54:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/iobuffer/ChangeLog,v 1.6 2012/03/14 15:06:42 matsuu Exp $
+
+*iobuffer-1.1.2 (14 Mar 2012)
+
+ 14 Mar 2012; MATSUU Takuto <matsuu@gentoo.org> +iobuffer-1.1.2.ebuild:
+ Version bumped. Clean up.
13 Jan 2012; Hans de Graaff <graaff@gentoo.org> iobuffer-1.0.0.ebuild:
Add ruby19.
diff --git a/dev-ruby/iobuffer/iobuffer-1.1.2.ebuild b/dev-ruby/iobuffer/iobuffer-1.1.2.ebuild
new file mode 100644
index 000000000000..f965451604dc
--- /dev/null
+++ b/dev-ruby/iobuffer/iobuffer-1.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/iobuffer/iobuffer-1.1.2.ebuild,v 1.1 2012/03/14 15:06:42 matsuu Exp $
+
+EAPI="4"
+# jruby: mkmf
+# rbx: Kernel(Autoload)#allocate (method_missing)
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="IO::Buffer is a fast byte queue which is primarily intended for non-blocking I/O applications"
+HOMEPAGE="http://mynyml.com/ruby/flexible-continuous-testing"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "Failed to configure the extension."
+ sed -i -e 's:-Wl,--no-undefined::' \
+ -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" ext/Makefile || die
+}
+
+each_ruby_compile() {
+ emake -C ext || die "Failed to compile the extension."
+ cp ext/iobuffer_ext.so lib/ || die
+}