summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-03 10:31:55 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-03 10:31:55 +0000
commit084eca81dd73303b486b63c0959df68a6abec2bf (patch)
treeaad8e4ac378ece560c7a86b02231406f7271f4c6 /dev-ruby
parentAdd ree18 support. (diff)
downloadgentoo-2-084eca81dd73303b486b63c0959df68a6abec2bf.tar.gz
gentoo-2-084eca81dd73303b486b63c0959df68a6abec2bf.tar.bz2
gentoo-2-084eca81dd73303b486b63c0959df68a6abec2bf.zip
Don't run tests on jruby, the sqlite3 dependency is not optional at the moment.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/i18n/ChangeLog6
-rw-r--r--dev-ruby/i18n/i18n-0.4.1.ebuild18
2 files changed, 19 insertions, 5 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index bb381aaa6aa0..a872abc3b25f 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.20 2010/09/29 22:17:38 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.21 2010/10/03 10:31:55 graaff Exp $
29 Sep 2010; Brent Baude <ranger@gentoo.org> i18n-0.3.7.ebuild:
Marking i18n-0.3.7 ~ppc64 for bug 321283
@@ -11,6 +11,10 @@
28 Sep 2010; Brent Baude <ranger@gentoo.org> i18n-0.1.3.ebuild:
Marking i18n-0.1.3 ~ppc for bug 319241
+ 05 Sep 2010; Hans de Graaff <graaff@gentoo.org> i18n-0.4.1.ebuild:
+ Don't run tests on jruby, the sqlite3 dependency is not optional at the
+ moment.
+
*i18n-0.4.1 (31 Aug 2010)
31 Aug 2010; Alex Legler <a3li@gentoo.org> +i18n-0.4.1.ebuild:
diff --git a/dev-ruby/i18n/i18n-0.4.1.ebuild b/dev-ruby/i18n/i18n-0.4.1.ebuild
index edb7a8d8a297..8e09e8e58a88 100644
--- a/dev-ruby/i18n/i18n-0.4.1.ebuild
+++ b/dev-ruby/i18n/i18n-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.4.1.ebuild,v 1.1 2010/08/31 17:50:17 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.4.1.ebuild,v 1.2 2010/10/03 10:31:55 graaff Exp $
EAPI=2
@@ -28,9 +28,8 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
-# Optionally, the testsuite uses the activerecord gem to run some
-# tests; whent hey run, they require sqlite3-ruby, and that is not
-# available on JRuby.
+# The testsuite uses the activerecord gem to run some tests; they
+# require sqlite3-ruby, and that is not available on JRuby.
USE_RUBY="${USE_RUBY/jruby/}" \
ruby_add_bdepend "
test? (
@@ -63,3 +62,14 @@ src_test() {
chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
ruby-ng_src_test
}
+
+each_ruby_test() {
+ # Make sure the optional activerecord tests are not run for jruby
+ # because we don't ship a compatible sqlite3
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ each_fakegem_test
+ esac
+}