summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-30 09:08:40 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-30 09:08:40 +0000
commit0299d8a488633ad70f5364fcd1d88b22a54393f3 (patch)
tree06f3d34e8e04edc5f59a796ca5b2102c0e9a5419 /dev-ruby
parentVersion bump (diff)
downloadgentoo-2-0299d8a488633ad70f5364fcd1d88b22a54393f3.tar.gz
gentoo-2-0299d8a488633ad70f5364fcd1d88b22a54393f3.tar.bz2
gentoo-2-0299d8a488633ad70f5364fcd1d88b22a54393f3.zip
Version bump. Fix (new) broken specs and run them. Drop keywords due to new dependency: #322053.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/treetop/ChangeLog8
-rw-r--r--dev-ruby/treetop/files/treetop-1.4.7-fix-tmpdir.patch19
-rw-r--r--dev-ruby/treetop/treetop-1.4.7.ebuild34
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/treetop/ChangeLog b/dev-ruby/treetop/ChangeLog
index 04d631efd3a3..d1838d8f1c63 100644
--- a/dev-ruby/treetop/ChangeLog
+++ b/dev-ruby/treetop/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/treetop
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.14 2010/04/27 05:59:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.15 2010/05/30 09:08:40 graaff Exp $
+
+*treetop-1.4.7 (30 May 2010)
+
+ 30 May 2010; Hans de Graaff <graaff@gentoo.org> +treetop-1.4.7.ebuild,
+ +files/treetop-1.4.7-fix-tmpdir.patch:
+ Version bump. Fix (new) broken specs and run them.
27 Apr 2010; Hans de Graaff <graaff@gentoo.org> -treetop-1.4.2.ebuild,
-treetop-1.4.3.ebuild, -treetop-1.4.4.ebuild:
diff --git a/dev-ruby/treetop/files/treetop-1.4.7-fix-tmpdir.patch b/dev-ruby/treetop/files/treetop-1.4.7-fix-tmpdir.patch
new file mode 100644
index 000000000000..f7fa882c15cb
--- /dev/null
+++ b/dev-ruby/treetop/files/treetop-1.4.7-fix-tmpdir.patch
@@ -0,0 +1,19 @@
+diff --git a/spec/compiler/tt_compiler_spec.rb b/spec/compiler/tt_compiler_spec.rb
+index a453ad5..946691c 100644
+--- a/spec/compiler/tt_compiler_spec.rb
++++ b/spec/compiler/tt_compiler_spec.rb
+@@ -8,11 +8,13 @@ ENV['PATH'] = File.expand_path(File.dirname(__FILE__) + '../../../bin' +
+ $LOAD_PATH.unshift(File.expand_path('../../../../lib', __FILE__))
+
+ describe "The 'tt' comand line compiler" do
++ before(:each) do
++ @tmpdir = Dir.tmpdir
++ end
+
+ context 'when processing a single grammar file' do
+ before(:each) do
+ # create a fresh but dumb grammar file for each example
+- @tmpdir = Dir.tmpdir
+ @test_base = "dumb-#{rand(1000)}"
+ @test_path = "#{@tmpdir}/#{@test_base}"
+ @test_grammar = "#{@test_path}.tt"
diff --git a/dev-ruby/treetop/treetop-1.4.7.ebuild b/dev-ruby/treetop/treetop-1.4.7.ebuild
new file mode 100644
index 000000000000..f3c45ae49803
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.7.ebuild,v 1.1 2010/05/30 09:08:40 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-fix-tmpdir.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rr dev-ruby/rspec )"
+ruby_add_rdepend ">=dev-ruby/polyglot-0.3.1"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Failed installing example files."
+}