summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-27 10:06:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-10-27 10:06:35 +0000
commit020f81ce5ef7338ec56e5f83b1ce94afab528e7e (patch)
tree699640b294924e84843efc3dd51d992aa4e2688c /dev-ruby
parentVersion bump wrt #281536, thanks to Nico R. Wohlgemuth for reporting. (diff)
downloadgentoo-2-020f81ce5ef7338ec56e5f83b1ce94afab528e7e.tar.gz
gentoo-2-020f81ce5ef7338ec56e5f83b1ce94afab528e7e.tar.bz2
gentoo-2-020f81ce5ef7338ec56e5f83b1ce94afab528e7e.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.15.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 15bbf216bdca..1b641ee9f00b 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.38 2009/10/25 11:51:47 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.39 2009/10/27 10:06:35 flameeyes Exp $
+
+*tzinfo-0.3.15 (27 Oct 2009)
+
+ 27 Oct 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +tzinfo-0.3.15.ebuild:
+ Version bump.
25 Oct 2009; Markus Meier <maekke@gentoo.org> tzinfo-0.3.13.ebuild:
amd64/x86 stable, bug #282207
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.15.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.15.ebuild
new file mode 100644
index 000000000000..661f12ff0d0b
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.15.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.15.ebuild,v 1.1 2009/10/27 10:06:35 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="Library to provide daylight-savings aware transformations between timezones"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-ruby/rake )
+ test? ( dev-ruby/rake )"
+
+USE_RUBY="ruby18 ruby19"
+
+src_unpack() {
+ unpack ${A}
+
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i -e '138,146s:^:#:' "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+src_compile() {
+ if use doc; then
+ rake rerdoc || die "rake rerdoc failed"
+ fi
+}
+
+src_test() {
+ for ruby in $USE_RUBY; do
+ [[ -n `type -p $ruby` ]] || continue
+ $ruby $(type -p rake) test || die "testsuite failed"
+ done
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ if use doc; then
+ dohtml -r "${S}"/doc/* || die "dohtml failed"
+ fi
+
+ dodoc "${S}"/CHANGES "${S}"/README || die "dodoc failed"
+
+ insinto $(${RUBY} -r rbconfig -e 'print Config::CONFIG["vendorlibdir"]' | sed -e 's:vendor_ruby:gems:')/specifications
+ sed -e "s:@VERSION@:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${T}"/${P}.gemspec
+ doins "${T}"/${P}.gemspec || die "Unable to install fake gemspec"
+}