summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-19 12:21:03 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-19 12:21:03 +0000
commit112195210800428366f636ae1708e43e5da6560a (patch)
tree94acb78f9a90e797bcb0b4ee2ffedb2ddad14cb5 /dev-ruby/xpath
parentSwitch ewarn to elog to inform about splitdebug, bug #466384 (diff)
downloadgentoo-2-112195210800428366f636ae1708e43e5da6560a.tar.gz
gentoo-2-112195210800428366f636ae1708e43e5da6560a.tar.bz2
gentoo-2-112195210800428366f636ae1708e43e5da6560a.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/xpath')
-rw-r--r--dev-ruby/xpath/ChangeLog9
-rw-r--r--dev-ruby/xpath/xpath-2.0.0.ebuild25
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-ruby/xpath/ChangeLog b/dev-ruby/xpath/ChangeLog
index f181e9714e24..bb5399ced7c5 100644
--- a/dev-ruby/xpath/ChangeLog
+++ b/dev-ruby/xpath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/xpath
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/ChangeLog,v 1.7 2012/11/21 07:10:04 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/ChangeLog,v 1.8 2013/04/19 12:21:03 graaff Exp $
+
+*xpath-2.0.0 (19 Apr 2013)
+
+ 19 Apr 2013; Hans de Graaff <graaff@gentoo.org> +xpath-2.0.0.ebuild:
+ Version bump.
21 Nov 2012; Hans de Graaff <graaff@gentoo.org> xpath-1.0.0.ebuild:
Add back jruby.
diff --git a/dev-ruby/xpath/xpath-2.0.0.ebuild b/dev-ruby/xpath/xpath-2.0.0.ebuild
new file mode 100644
index 000000000000..b3f466738c14
--- /dev/null
+++ b/dev-ruby/xpath/xpath-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/xpath-2.0.0.ebuild,v 1.1 2013/04/19 12:21:03 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0."
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' spec/spec_helper.rb || die
+}