summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-18 14:10:09 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-18 14:10:09 +0000
commit085acae26d5d080ea4b7ac1658616499b56b32c0 (patch)
treea8f02b36403da249c9eed7fd0263b273213d4e05 /dev-ruby/xpath
parentdrop one more useless die, since the ebuilds are eapi4 and emake dies on its own (diff)
downloadgentoo-2-085acae26d5d080ea4b7ac1658616499b56b32c0.tar.gz
gentoo-2-085acae26d5d080ea4b7ac1658616499b56b32c0.tar.bz2
gentoo-2-085acae26d5d080ea4b7ac1658616499b56b32c0.zip
Initial import. Dependency of forthcoming capybara.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/xpath')
-rw-r--r--dev-ruby/xpath/ChangeLog10
-rw-r--r--dev-ruby/xpath/metadata.xml5
-rw-r--r--dev-ruby/xpath/xpath-0.1.4.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/xpath/ChangeLog b/dev-ruby/xpath/ChangeLog
new file mode 100644
index 000000000000..aa9e544f68e9
--- /dev/null
+++ b/dev-ruby/xpath/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/xpath
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/ChangeLog,v 1.1 2011/05/18 14:10:09 graaff Exp $
+
+*xpath-0.1.4 (18 May 2011)
+
+ 18 May 2011; Hans de Graaff <graaff@gentoo.org> +xpath-0.1.4.ebuild,
+ +metadata.xml:
+ Initial import. Dependency of forthcoming capybara.
+
diff --git a/dev-ruby/xpath/metadata.xml b/dev-ruby/xpath/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/xpath/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/xpath/xpath-0.1.4.ebuild b/dev-ruby/xpath/xpath-0.1.4.ebuild
new file mode 100644
index 000000000000..ca1b7b2107f2
--- /dev/null
+++ b/dev-ruby/xpath/xpath-0.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/xpath/xpath-0.1.4.ebuild,v 1.1 2011/05/18 14:10:09 graaff Exp $
+
+EAPI="4"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="XPath is a Ruby DSL around a subset of XPath 1.0."
+HOMEPAGE="https://github.com/jnicklas/xpath"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rspec spec || die "Tests failed."
+}