summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-07-07 06:16:21 +0000
committerHans de Graaff <graaff@gentoo.org>2009-07-07 06:16:21 +0000
commit0e08291f1063d8d42b19097f947f57f24cc9c181 (patch)
tree8b48c73f5f39c2c0ab9ede7363d23ae6ca5e56b7 /dev-ruby/wirble
parentRevision bump (diff)
downloadgentoo-2-0e08291f1063d8d42b19097f947f57f24cc9c181.tar.gz
gentoo-2-0e08291f1063d8d42b19097f947f57f24cc9c181.tar.bz2
gentoo-2-0e08291f1063d8d42b19097f947f57f24cc9c181.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/wirble')
-rw-r--r--dev-ruby/wirble/ChangeLog9
-rw-r--r--dev-ruby/wirble/wirble-0.1.3.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-ruby/wirble/ChangeLog b/dev-ruby/wirble/ChangeLog
index afd829438b0d..5765b24acd95 100644
--- a/dev-ruby/wirble/ChangeLog
+++ b/dev-ruby/wirble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/wirble
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wirble/ChangeLog,v 1.7 2008/04/12 18:04:20 ken69267 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wirble/ChangeLog,v 1.8 2009/07/07 06:16:21 graaff Exp $
+
+*wirble-0.1.3 (07 Jul 2009)
+
+ 07 Jul 2009; Hans de Graaff <graaff@gentoo.org> +wirble-0.1.3.ebuild:
+ Version bump.
12 Apr 2008; Kenneth Prugh <ken69267@gentoo.org> wirble-0.1.2.ebuild:
amd64 stable, bug #217327
diff --git a/dev-ruby/wirble/wirble-0.1.3.ebuild b/dev-ruby/wirble/wirble-0.1.3.ebuild
new file mode 100644
index 000000000000..ad2583dc440c
--- /dev/null
+++ b/dev-ruby/wirble/wirble-0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/wirble/wirble-0.1.3.ebuild,v 1.1 2009/07/07 06:16:21 graaff Exp $
+
+inherit ruby gems
+
+USE_RUBY="ruby18"
+DESCRIPTION="Wirble is a set of enhancements for Irb."
+HOMEPAGE="http://pablotron.org/software/wirble/"
+SRC_URI="http://gems.rubyforge.org/gems/${P}.gem"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND=""
+IUSE=""
+
+pkg_postinst() {
+ elog "The quick way to use wirble is to make your ~/.irbrc look like this:"
+ elog " # load libraries"
+ elog " require 'rubygems'"
+ elog " require 'wirble'"
+ elog " "
+ elog " # start wirble (with color)"
+ elog " Wirble.init"
+ elog " Wirble.colorize"
+}