summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-20 13:15:34 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-20 13:15:34 +0000
commit647515bc67c168b90b97ecd6334ca5b0ee1a0d46 (patch)
tree72d13c05bc4540288e4bc57353bf0d613919fe09 /dev-ruby/will_paginate
parentAlways depend on dev-ruby/rake since we use it to build the package. Fixes bu... (diff)
downloadgentoo-2-647515bc67c168b90b97ecd6334ca5b0ee1a0d46.tar.gz
gentoo-2-647515bc67c168b90b97ecd6334ca5b0ee1a0d46.tar.bz2
gentoo-2-647515bc67c168b90b97ecd6334ca5b0ee1a0d46.zip
Fix tests in the presence of Rails 3.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/will_paginate')
-rw-r--r--dev-ruby/will_paginate/ChangeLog6
-rw-r--r--dev-ruby/will_paginate/will_paginate-2.3.15.ebuild10
2 files changed, 13 insertions, 3 deletions
diff --git a/dev-ruby/will_paginate/ChangeLog b/dev-ruby/will_paginate/ChangeLog
index cf2ac7760f7f..27f720d6403e 100644
--- a/dev-ruby/will_paginate/ChangeLog
+++ b/dev-ruby/will_paginate/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/will_paginate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.11 2011/01/10 18:18:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/ChangeLog,v 1.12 2011/02/20 13:15:34 graaff Exp $
+
+ 20 Feb 2011; Hans de Graaff <graaff@gentoo.org>
+ will_paginate-2.3.15.ebuild:
+ Fix tests in the presence of Rails 3.
10 Jan 2011; Hans de Graaff <graaff@gentoo.org>
will_paginate-2.3.15.ebuild:
diff --git a/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild b/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild
index 45391366bb81..4da55f094e77 100644
--- a/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild
+++ b/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild,v 1.2 2011/01/10 18:18:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/will_paginate/will_paginate-2.3.15.ebuild,v 1.3 2011/02/20 13:15:34 graaff Exp $
EAPI=2
USE_RUBY="ruby18"
@@ -22,8 +22,14 @@ ruby_add_bdepend "
test? (
dev-ruby/mocha
dev-ruby/rack
- dev-ruby/activerecord
+ dev-ruby/rails:2.3
virtual/ruby-test-unit
!dev-ruby/test-unit:2
)"
ruby_add_rdepend '>=dev-ruby/activesupport-1.4.4'
+
+each_ruby_test() {
+ # Only works with 2.3.x, so guard against rails 3 being installed
+ # already.
+ RAILS_VERSION="~>2.3.5" rake test || die "Tests failed."
+}