summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-01 14:59:57 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-01 14:59:57 +0000
commit52ddbe8f2b0c9ed0bb4f8b4856958aad40ec11cf (patch)
tree8fb02b3608ae04a1cfb066a8d1eb0c8080b55729 /dev-ruby/weakling
parentppc/ppc64 stable wrt #363767 (diff)
downloadgentoo-2-52ddbe8f2b0c9ed0bb4f8b4856958aad40ec11cf.tar.gz
gentoo-2-52ddbe8f2b0c9ed0bb4f8b4856958aad40ec11cf.tar.bz2
gentoo-2-52ddbe8f2b0c9ed0bb4f8b4856958aad40ec11cf.zip
Compile the jar file instead of using the shipped version. Thanks for James Le Cuirot for the ebuild and investigation in bug 365463.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/weakling')
-rw-r--r--dev-ruby/weakling/ChangeLog8
-rw-r--r--dev-ruby/weakling/weakling-0.0.3-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/weakling/ChangeLog b/dev-ruby/weakling/ChangeLog
index c3702a2b5aa4..db2557dbd643 100644
--- a/dev-ruby/weakling/ChangeLog
+++ b/dev-ruby/weakling/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/weakling
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/weakling/ChangeLog,v 1.1 2011/04/30 15:13:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/weakling/ChangeLog,v 1.2 2011/05/01 14:59:57 graaff Exp $
+
+*weakling-0.0.3-r1 (01 May 2011)
+
+ 01 May 2011; Hans de Graaff <graaff@gentoo.org> +weakling-0.0.3-r1.ebuild:
+ Compile the jar file instead of using the shipped version. Thanks for
+ James Le Cuirot for the ebuild and investigation in bug 365463.
*weakling-0.0.3 (30 Apr 2011)
diff --git a/dev-ruby/weakling/weakling-0.0.3-r1.ebuild b/dev-ruby/weakling/weakling-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..f5789cacdf59
--- /dev/null
+++ b/dev-ruby/weakling/weakling-0.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/weakling/weakling-0.0.3-r1.ebuild,v 1.1 2011/05/01 14:59:57 graaff Exp $
+
+EAPI=2
+
+# This package is specifically for JRuby.
+USE_RUBY="jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY.txt README.txt"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit java-pkg-2 java-pkg-simple ruby-fakegem
+
+DESCRIPTION="weakling: a collection of weakref utilities for Ruby"
+HOMEPAGE="http://github.com/headius/weakling"
+LICENSE="Apache-2.0" # Not distributed in gem but in github repository
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-java/bytelist
+ dev-java/jruby"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+JAVA_GENTOO_CLASSPATH="bytelist jruby"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+ ruby-ng_pkg_setup
+}
+
+each_ruby_compile() {
+ java-pkg-simple_src_compile
+ cp "${PN}.jar" "lib/refqueue.jar" || die
+}