summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-11 07:25:03 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-11 07:25:03 +0000
commit7629c29e65d7cdebc9724f6f41ac1be00c349321 (patch)
treef0e8543ba600b756e0fea6add4d2dc29bf8d8a93 /dev-ruby/vlad
parentVersion bump. (diff)
downloadgentoo-2-7629c29e65d7cdebc9724f6f41ac1be00c349321.tar.gz
gentoo-2-7629c29e65d7cdebc9724f6f41ac1be00c349321.tar.bz2
gentoo-2-7629c29e65d7cdebc9724f6f41ac1be00c349321.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/vlad')
-rw-r--r--dev-ruby/vlad/ChangeLog7
-rw-r--r--dev-ruby/vlad/vlad-2.3.1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/vlad/ChangeLog b/dev-ruby/vlad/ChangeLog
index 0a1e094348f5..f11d13636a38 100644
--- a/dev-ruby/vlad/ChangeLog
+++ b/dev-ruby/vlad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/vlad
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.19 2012/09/24 16:20:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.20 2012/12/11 07:25:03 graaff Exp $
+
+*vlad-2.3.1 (11 Dec 2012)
+
+ 11 Dec 2012; Hans de Graaff <graaff@gentoo.org> +vlad-2.3.1.ebuild:
+ Version bump.
24 Sep 2012; Hans de Graaff <graaff@gentoo.org> -vlad-2.2.4.ebuild:
Cleanup.
diff --git a/dev-ruby/vlad/vlad-2.3.1.ebuild b/dev-ruby/vlad/vlad-2.3.1.ebuild
new file mode 100644
index 000000000000..2e7ddf84e0ee
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/vlad-2.3.1.ebuild,v 1.1 2012/12/11 07:25:03 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy."
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.1"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}