summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-01 18:19:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-01 18:19:52 +0000
commita8f64eeffd6399f6b857a3794c4cf4ae5ce1cc55 (patch)
treec1f63b585e90966a6ee161c88017ff3e545b090c /dev-ruby/uuidtools
parentold (diff)
downloadgentoo-2-a8f64eeffd6399f6b857a3794c4cf4ae5ce1cc55.tar.gz
gentoo-2-a8f64eeffd6399f6b857a3794c4cf4ae5ce1cc55.tar.bz2
gentoo-2-a8f64eeffd6399f6b857a3794c4cf4ae5ce1cc55.zip
Version bump; use tarball rather than gem: the installed package is smaller, it has no rake/rspec dependencies, and tests are executed with FEATURES=test.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'dev-ruby/uuidtools')
-rw-r--r--dev-ruby/uuidtools/ChangeLog10
-rw-r--r--dev-ruby/uuidtools/uuidtools-1.0.5.ebuild48
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-ruby/uuidtools/ChangeLog b/dev-ruby/uuidtools/ChangeLog
index 47d09ba1ff12..242faab2ea95 100644
--- a/dev-ruby/uuidtools/ChangeLog
+++ b/dev-ruby/uuidtools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/uuidtools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/ChangeLog,v 1.3 2008/11/03 06:17:31 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/ChangeLog,v 1.4 2008/12/01 18:19:52 flameeyes Exp $
+
+*uuidtools-1.0.5 (01 Dec 2008)
+
+ 01 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ +uuidtools-1.0.5.ebuild:
+ Version bump; use tarball rather than gem: the installed package is
+ smaller, it has no rake/rspec dependencies, and tests are executed with
+ FEATURES=test.
03 Nov 2008; Hans de Graaff <graaff@gentoo.org> uuidtools-1.0.4.ebuild:
Keywording ~x86, works fine there
diff --git a/dev-ruby/uuidtools/uuidtools-1.0.5.ebuild b/dev-ruby/uuidtools/uuidtools-1.0.5.ebuild
new file mode 100644
index 000000000000..80be759ecc7c
--- /dev/null
+++ b/dev-ruby/uuidtools/uuidtools-1.0.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/uuidtools-1.0.5.ebuild,v 1.1 2008/12/01 18:19:52 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="Simple library to generate UUIDs"
+HOMEPAGE="http://uuidtools.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test doc"
+
+DEPEND="doc? ( dev-ruby/rake )
+ test? ( dev-ruby/rake )
+ test? ( >=dev-ruby/rspec-1.0.8 )"
+RDEPEND=""
+
+USE_RUBY="ruby18"
+
+src_unpack() {
+ unpack ${A}
+
+ find . -name '._*.rb' -delete || die "unable to remove mac files"
+}
+
+src_compile() {
+ if use doc; then
+ rake doc || die "rake doc failed"
+ fi
+}
+
+src_test() {
+ rake spec:normal || die "rake spec failed"
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ if use doc; then
+ dohtml -r "${S}"/doc/* || die "dohtml failed"
+ fi
+
+ dodoc "${S}"/CHANGELOG "${S}"/README || die "dodoc failed"
+}