summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-08-21 17:55:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-08-21 17:55:01 +0000
commit2494d71e72d73bdf83e376dc8ae9ebb0dac07b17 (patch)
treefa24790a12ce36564699bc51460174d4a205c8e1 /dev-ruby/tzinfo
parentVersion bump. (diff)
downloadgentoo-2-2494d71e72d73bdf83e376dc8ae9ebb0dac07b17.tar.gz
gentoo-2-2494d71e72d73bdf83e376dc8ae9ebb0dac07b17.tar.bz2
gentoo-2-2494d71e72d73bdf83e376dc8ae9ebb0dac07b17.zip
Version bump.
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.14.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 9a2e5eba9df3..4411ea70f7eb 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.35 2009/06/13 10:46:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.36 2009/08/21 17:55:01 flameeyes Exp $
+
+*tzinfo-0.3.14 (21 Aug 2009)
+
+ 21 Aug 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +tzinfo-0.3.14.ebuild:
+ Version bump.
13 Jun 2009; Hans de Graaff <graaff@gentoo.org> -tzinfo-0.3.11.ebuild,
-tzinfo-0.3.12.ebuild, tzinfo-0.3.13.ebuild:
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.14.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.14.ebuild
new file mode 100644
index 000000000000..2f1dd986e6f1
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.14.ebuild,v 1.1 2009/08/21 17:55:01 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="Library to provide daylight-savings aware transformations between timezones"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-ruby/rake )
+ test? ( dev-ruby/rake )"
+
+USE_RUBY="ruby18 ruby19"
+
+src_unpack() {
+ unpack ${A}
+
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ [[ "${PV}" != "0.3.14" ]] && die "Hey you still got a 0.3.14-specific hack!"
+ sed -i -e '138,146s:^:#:' "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}
+
+src_compile() {
+ if use doc; then
+ rake rerdoc || die "rake rerdoc failed"
+ fi
+}
+
+src_test() {
+ for ruby in $USE_RUBY; do
+ [[ -n `type -p $ruby` ]] || continue
+ $ruby $(type -p rake) test || die "testsuite failed"
+ done
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ if use doc; then
+ dohtml -r "${S}"/doc/* || die "dohtml failed"
+ fi
+
+ dodoc "${S}"/CHANGES "${S}"/README || die "dodoc failed"
+
+ insinto $(${RUBY} -r rbconfig -e 'print Config::CONFIG["vendorlibdir"]' | sed -e 's:vendor_ruby:gems:')/specifications
+ sed -e "s:@VERSION@:${PV}:" "${FILESDIR}"/${PN}.gemspec > "${T}"/${P}.gemspec
+ doins "${T}"/${P}.gemspec || die "Unable to install fake gemspec"
+}