summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-06 00:30:23 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-06 00:30:23 +0000
commit16dae7375c8b3d47260eef803e0bfde5184fd6e0 (patch)
treef47e90ae9cd3d1ec160edb7ec16cf68a125c2c04 /dev-ruby/tzinfo
parentRemoved the unneeded execution of matchbox-desktop during ./configure, thanks... (diff)
downloadgentoo-2-16dae7375c8b3d47260eef803e0bfde5184fd6e0.tar.gz
gentoo-2-16dae7375c8b3d47260eef803e0bfde5184fd6e0.tar.bz2
gentoo-2-16dae7375c8b3d47260eef803e0bfde5184fd6e0.zip
Version bump.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog8
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.16.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 7780957effe2..07dfddfa973a 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.45 2010/01/04 12:01:39 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.46 2010/01/06 00:30:23 flameeyes Exp $
+
+*tzinfo-0.3.16 (06 Jan 2010)
+
+ 06 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +tzinfo-0.3.16.ebuild:
+ Version bump.
04 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
tzinfo-0.3.15-r1.ebuild:
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.16.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.16.ebuild
new file mode 100644
index 000000000000..31f071ff93e0
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.16.ebuild,v 1.1 2010/01/06 00:30:23 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Daylight-savings aware timezone library"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+
+ # With rubygems 1.3.1 we get the following warning
+ # warning: Insecure world writable dir /var/tmp in LOAD_PATH, mode 041777
+ # when running the test_get_tainted_not_loaded test.
+ sed -i -e '138,146s:^:#:' "${S}"/test/tc_timezone.rb || die "unable to sed out the test"
+}