summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-24 16:04:56 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-24 16:04:56 +0000
commit593a36b410c6fd8590d85d519981b063001af142 (patch)
tree054db7a3dda182ccce45f27c6593d2bb1ecd4732 /dev-ruby/twitter
parentcleanup + EAPI4 bump (diff)
downloadgentoo-2-593a36b410c6fd8590d85d519981b063001af142.tar.gz
gentoo-2-593a36b410c6fd8590d85d519981b063001af142.tar.bz2
gentoo-2-593a36b410c6fd8590d85d519981b063001af142.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/twitter')
-rw-r--r--dev-ruby/twitter/ChangeLog7
-rw-r--r--dev-ruby/twitter/twitter-3.7.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/twitter/ChangeLog b/dev-ruby/twitter/ChangeLog
index a43284592bee..5be87c0cbff1 100644
--- a/dev-ruby/twitter/ChangeLog
+++ b/dev-ruby/twitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/twitter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/twitter/ChangeLog,v 1.27 2012/06/10 06:08:48 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/twitter/ChangeLog,v 1.28 2012/09/24 16:04:56 graaff Exp $
+
+*twitter-3.7.0 (24 Sep 2012)
+
+ 24 Sep 2012; Hans de Graaff <graaff@gentoo.org> +twitter-3.7.0.ebuild:
+ Version bump.
*twitter-2.5.0 (10 Jun 2012)
diff --git a/dev-ruby/twitter/twitter-3.7.0.ebuild b/dev-ruby/twitter/twitter-3.7.0.ebuild
new file mode 100644
index 000000000000..b8dfbc3b0a1c
--- /dev/null
+++ b/dev-ruby/twitter/twitter-3.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/twitter/twitter-3.7.0.ebuild,v 1.1 2012/09/24 16:04:56 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby wrapper around the Twitter API"
+HOMEPAGE="http://twitter.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/faraday-0*
+ >=dev-ruby/faraday-0.8
+ >=dev-ruby/multi_json-1.3
+ =dev-ruby/multi_json-1*
+ =dev-ruby/simple_oauth-0.1*
+ >=dev-ruby/simple_oauth-0.1.6"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:2
+ dev-ruby/webmock
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+# rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die "Unable to remove bundler code."
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}