summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-20 07:37:16 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-20 07:37:16 +0000
commit5b6221c5ca8b4b3d6b4965b6a3ea4cb04333c374 (patch)
treed9b463716611c5a0a92d15149b784f4cd8589b58 /dev-ruby/treetop
parentold (diff)
downloadgentoo-2-5b6221c5ca8b4b3d6b4965b6a3ea4cb04333c374.tar.gz
gentoo-2-5b6221c5ca8b4b3d6b4965b6a3ea4cb04333c374.tar.bz2
gentoo-2-5b6221c5ca8b4b3d6b4965b6a3ea4cb04333c374.zip
Version bump.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/treetop')
-rw-r--r--dev-ruby/treetop/ChangeLog7
-rw-r--r--dev-ruby/treetop/treetop-1.4.4.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/treetop/ChangeLog b/dev-ruby/treetop/ChangeLog
index 357b540a5a98..00f70e80588b 100644
--- a/dev-ruby/treetop/ChangeLog
+++ b/dev-ruby/treetop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/treetop
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.11 2010/02/13 19:36:52 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/ChangeLog,v 1.12 2010/02/20 07:37:16 graaff Exp $
+
+*treetop-1.4.4 (20 Feb 2010)
+
+ 20 Feb 2010; Hans de Graaff <graaff@gentoo.org> +treetop-1.4.4.ebuild:
+ Version bump.
13 Feb 2010; Raúl Porcel <armin76@gentoo.org> treetop-1.4.2.ebuild,
treetop-1.4.3.ebuild:
diff --git a/dev-ruby/treetop/treetop-1.4.4.ebuild b/dev-ruby/treetop/treetop-1.4.4.ebuild
new file mode 100644
index 000000000000..f4571793dc13
--- /dev/null
+++ b/dev-ruby/treetop/treetop-1.4.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/treetop/treetop-1.4.4.ebuild,v 1.1 2010/02/20 07:37:16 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Treetop is a language for describing languages."
+HOMEPAGE="http://treetop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/polyglot-0.2.5"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Failed installing example files."
+}