summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-05-01 04:45:03 +0000
committerHans de Graaff <graaff@gentoo.org>2015-05-01 04:45:03 +0000
commitf22e097504dd0f4293031a84325e3d67595b38b8 (patch)
tree377af4d91d2288144e2ac7f5db8f1aa67234362a /dev-ruby/tins/tins-1.5.1.ebuild
parentStable for HPPA PPC64 (bug #548176). (diff)
downloadgentoo-2-f22e097504dd0f4293031a84325e3d67595b38b8.tar.gz
gentoo-2-f22e097504dd0f4293031a84325e3d67595b38b8.tar.bz2
gentoo-2-f22e097504dd0f4293031a84325e3d67595b38b8.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/tins/tins-1.5.1.ebuild')
-rw-r--r--dev-ruby/tins/tins-1.5.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/tins/tins-1.5.1.ebuild b/dev-ruby/tins/tins-1.5.1.ebuild
new file mode 100644
index 000000000000..9681e17c0c7f
--- /dev/null
+++ b/dev-ruby/tins/tins-1.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-1.5.1.ebuild,v 1.1 2015/05/01 04:45:03 graaff Exp $
+
+EAPI=5
+# Ruby 1.9 fails tests
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library"
+HOMEPAGE="https://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}