summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-20 11:06:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-20 11:06:35 +0000
commite84d77cb8f9471ed14b46243c7c356cf9010bfaa (patch)
tree2a8d43eec86fc72563db465f83a6273b0bf78909 /dev-ruby/thor
parentFixed sqlite dependency (bug #341869). (diff)
downloadgentoo-2-e84d77cb8f9471ed14b46243c7c356cf9010bfaa.tar.gz
gentoo-2-e84d77cb8f9471ed14b46243c7c356cf9010bfaa.tar.bz2
gentoo-2-e84d77cb8f9471ed14b46243c7c356cf9010bfaa.zip
Fix build with USE=-doc (bug #341881).
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/ChangeLog6
-rw-r--r--dev-ruby/thor/thor-0.14.0.ebuild6
-rw-r--r--dev-ruby/thor/thor-0.14.2.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
index 1528353bfedf..77645cddb587 100644
--- a/dev-ruby/thor/ChangeLog
+++ b/dev-ruby/thor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/thor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.2 2010/10/02 11:41:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.3 2010/10/20 11:06:35 flameeyes Exp $
+
+ 20 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org> thor-0.14.0.ebuild,
+ thor-0.14.2.ebuild:
+ Fix build with USE=-doc (bug #341881).
*thor-0.14.2 (02 Oct 2010)
diff --git a/dev-ruby/thor/thor-0.14.0.ebuild b/dev-ruby/thor/thor-0.14.0.ebuild
index 5916d1d95a69..1a3fa7929766 100644
--- a/dev-ruby/thor/thor-0.14.0.ebuild
+++ b/dev-ruby/thor/thor-0.14.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.0.ebuild,v 1.1 2010/08/31 20:14:24 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.0.ebuild,v 1.2 2010/10/20 11:06:35 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19"
@@ -36,7 +36,9 @@ all_ruby_prepare() {
all_ruby_compile() {
einfo $(pwd)
- use doc && ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+ if use doc; then
+ ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+ fi
}
each_ruby_test() {
diff --git a/dev-ruby/thor/thor-0.14.2.ebuild b/dev-ruby/thor/thor-0.14.2.ebuild
index a2ce8aa01c15..a7903c6d0fa1 100644
--- a/dev-ruby/thor/thor-0.14.2.ebuild
+++ b/dev-ruby/thor/thor-0.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.2.ebuild,v 1.1 2010/10/02 11:41:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.2.ebuild,v 1.2 2010/10/20 11:06:35 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ree18 ruby19"
@@ -36,7 +36,9 @@ all_ruby_prepare() {
all_ruby_compile() {
einfo $(pwd)
- use doc && ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+ if use doc; then
+ ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+ fi
}
each_ruby_test() {