summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-28 08:53:21 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-28 08:53:21 +0000
commit8253d2c40d24a2296ccbdb3d511aa5961d230143 (patch)
treef7b6aa4efc7b222512580c7d363f5e4a72cf0b1d /dev-ruby/thor
parentVersion bump. (diff)
downloadgentoo-2-8253d2c40d24a2296ccbdb3d511aa5961d230143.tar.gz
gentoo-2-8253d2c40d24a2296ccbdb3d511aa5961d230143.tar.bz2
gentoo-2-8253d2c40d24a2296ccbdb3d511aa5961d230143.zip
Cleanup.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/ChangeLog6
-rw-r--r--dev-ruby/thor/thor-0.14.6.ebuild49
-rw-r--r--dev-ruby/thor/thor-0.15.2.ebuild60
-rw-r--r--dev-ruby/thor/thor-0.18.1.ebuild48
4 files changed, 5 insertions, 158 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
index c478e2b5beb1..3b0195bb5298 100644
--- a/dev-ruby/thor/ChangeLog
+++ b/dev-ruby/thor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/thor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.23 2014/11/25 11:34:25 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.24 2014/12/28 08:53:21 graaff Exp $
+
+ 28 Dec 2014; Hans de Graaff <graaff@gentoo.org> -thor-0.14.6.ebuild,
+ -thor-0.15.2.ebuild, -thor-0.18.1.ebuild:
+ Cleanup.
25 Nov 2014; Manuel Rüger <mrueg@gentoo.org> thor-0.15.2.ebuild,
thor-0.18.1.ebuild, thor-0.19.1.ebuild:
diff --git a/dev-ruby/thor/thor-0.14.6.ebuild b/dev-ruby/thor/thor-0.14.6.ebuild
deleted file mode 100644
index b8b6261caf0b..000000000000
--- a/dev-ruby/thor/thor-0.14.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.6.ebuild,v 1.9 2014/04/05 14:35:29 mrueg Exp $
-
-EAPI=2
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://github.com/wycats/thor"
-
-SRC_URI="http://github.com/wycats/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/wycats-${PN}-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-ruby_add_bdepend "
- test? ( dev-ruby/fakeweb dev-ruby/rspec:2 )
- doc? ( dev-ruby/rdoc )"
-
-all_ruby_prepare() {
- # Remove Bundler
- rm Gemfile Gemfile.lock || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '3,7d' spec/spec_helper.rb || die
-}
-
-all_ruby_compile() {
- if use doc; then
- ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
- fi
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib/ bin/thor spec || die "Tests for ${RUBY} failed"
-}
diff --git a/dev-ruby/thor/thor-0.15.2.ebuild b/dev-ruby/thor/thor-0.15.2.ebuild
deleted file mode 100644
index 45d365690e9f..000000000000
--- a/dev-ruby/thor/thor-0.15.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.15.2.ebuild,v 1.5 2014/11/25 11:34:25 mrueg Exp $
-
-EAPI=4
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-RUBY_S="wycats-${PN}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://github.com/wycats/thor"
-
-SRC_URI="http://github.com/wycats/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE="doc"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/fakeweb
- dev-ruby/rspec:2
- dev-ruby/childlabor
- )
- doc? (
- dev-ruby/rdoc
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/, /^end/ d' spec/spec_helper.rb || die
-}
-
-all_ruby_compile() {
- if use doc; then
- ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
- fi
-}
-
-each_ruby_test() {
- ${RUBY} -S rspec spec || die "Tests for ${RUBY} failed"
-}
diff --git a/dev-ruby/thor/thor-0.18.1.ebuild b/dev-ruby/thor/thor-0.18.1.ebuild
deleted file mode 100644
index 279ab3c27950..000000000000
--- a/dev-ruby/thor/thor-0.18.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.18.1.ebuild,v 1.6 2014/11/25 11:34:25 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_BINWRAP="thor"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A scripting framework that replaces rake and sake"
-HOMEPAGE="http://whatisthor.com/"
-
-SRC_URI="http://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/fakeweb-1.3
- dev-ruby/childlabor
- )"
-
-all_ruby_prepare() {
- # Remove rspec default options (as we might not have the last
- # rspec).
- rm .rspec || die
-
- # Remove Bundler
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Thorfile || die
-
- # Remove mandatory coverage collection using simplecov which is not
- # packaged.
- sed -i -e '/require .simplecov/,/SimpleCov.start/ s:^:#:' spec/helper.rb || die
-
- # Avoid a spec that requires UTF-8 support, so LANG=C still works,
- # bug 430402
- sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
-}