summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 18:33:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 18:33:47 +0000
commit24998270ab09a80ed245a4c92de3c001b2bdfe52 (patch)
treeb2e9583ac05236fd71b4495f4ad58a53928ec167 /dev-ruby/text-hyphen
parentUpdate to new syntax. (diff)
downloadgentoo-2-24998270ab09a80ed245a4c92de3c001b2bdfe52.tar.gz
gentoo-2-24998270ab09a80ed245a4c92de3c001b2bdfe52.tar.bz2
gentoo-2-24998270ab09a80ed245a4c92de3c001b2bdfe52.zip
Move non-ruby18 support to a new revision to mark one stable. Update to new syntax.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/text-hyphen')
-rw-r--r--dev-ruby/text-hyphen/ChangeLog9
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild10
-rw-r--r--dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild33
3 files changed, 48 insertions, 4 deletions
diff --git a/dev-ruby/text-hyphen/ChangeLog b/dev-ruby/text-hyphen/ChangeLog
index 759c930fbda0..76b3e025f755 100644
--- a/dev-ruby/text-hyphen/ChangeLog
+++ b/dev-ruby/text-hyphen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/text-hyphen
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/ChangeLog,v 1.18 2010/05/22 22:43:18 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/ChangeLog,v 1.19 2010/08/01 18:33:47 flameeyes Exp $
+
+*text-hyphen-1.0.0-r2 (01 Aug 2010)
+
+ 01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ text-hyphen-1.0.0-r1.ebuild, +text-hyphen-1.0.0-r2.ebuild:
+ Move non-ruby18 support to a new revision to mark one stable. Update to
+ new syntax.
22 May 2010; Alex Legler <a3li@gentoo.org> text-hyphen-1.0.0-r1.ebuild:
Add REE18 support
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild
index b988de183b3a..2b8771afccc2 100644
--- a/dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild
+++ b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild,v 1.7 2010/05/22 22:43:18 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/text-hyphen-1.0.0-r1.ebuild,v 1.8 2010/08/01 18:33:47 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ree18 ruby19 jruby"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README Changelog"
@@ -19,7 +19,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
IUSE=""
-ruby_add_bdepend test "dev-ruby/archive-tar-minitar virtual/ruby-test-unit"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/archive-tar-minitar
+ virtual/ruby-test-unit
+ )"
all_ruby_prepare() {
# Fix rakefile for new rake versions
diff --git a/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..60029bc04cd5
--- /dev/null
+++ b/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/text-hyphen/text-hyphen-1.0.0-r2.ebuild,v 1.1 2010/08/01 18:33:47 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README Changelog"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Hyphenates various words according to the rules of the language the word is written in."
+HOMEPAGE="http://rubyforge.org/projects/text-format"
+SRC_URI="mirror://rubyforge/text-format/${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/archive-tar-minitar
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Fix rakefile for new rake versions
+ sed -i -e 's: if t\.verbose::' Rakefile || die
+
+ epatch "${FILESDIR}/${P}+ruby-1.9.patch"
+}