summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-02 13:27:36 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-02 13:27:36 +0000
commitf5b1c9c1df4cd76d55a02fd82880305449e0d936 (patch)
tree90cc3768dbd8ecfe11c49b0433ea3a61768c5f59 /dev-ruby/test-unit
parentStable for x86, wrt bug #418673 (diff)
downloadgentoo-2-f5b1c9c1df4cd76d55a02fd82880305449e0d936.tar.gz
gentoo-2-f5b1c9c1df4cd76d55a02fd82880305449e0d936.tar.bz2
gentoo-2-f5b1c9c1df4cd76d55a02fd82880305449e0d936.zip
Remove old versions.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog6
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.0.ebuild59
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.2.ebuild59
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.3.ebuild59
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.5.ebuild59
5 files changed, 5 insertions, 237 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 2929903f9545..93154b166a31 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.52 2012/03/07 06:55:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.53 2012/06/02 13:27:36 graaff Exp $
+
+ 02 Jun 2012; Hans de Graaff <graaff@gentoo.org> -test-unit-2.4.0.ebuild,
+ -test-unit-2.4.2.ebuild, -test-unit-2.4.3.ebuild, -test-unit-2.4.5.ebuild:
+ Remove old versions.
*test-unit-2.4.8 (07 Mar 2012)
diff --git a/dev-ruby/test-unit/test-unit-2.4.0.ebuild b/dev-ruby/test-unit/test-unit-2.4.0.ebuild
deleted file mode 100644
index 2d332e03ed16..000000000000
--- a/dev-ruby/test-unit/test-unit-2.4.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.0.ebuild,v 1.4 2012/01/03 18:16:42 jer Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 doc" "( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.4.2.ebuild b/dev-ruby/test-unit/test-unit-2.4.2.ebuild
deleted file mode 100644
index 60d23ef78b48..000000000000
--- a/dev-ruby/test-unit/test-unit-2.4.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.2.ebuild,v 1.2 2012/01/03 18:16:42 jer Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 doc" "( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.4.3.ebuild b/dev-ruby/test-unit/test-unit-2.4.3.ebuild
deleted file mode 100644
index f0a5166d2b21..000000000000
--- a/dev-ruby/test-unit/test-unit-2.4.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.3.ebuild,v 1.3 2012/01/03 18:16:42 jer Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 doc" "( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.4.5.ebuild b/dev-ruby/test-unit/test-unit-2.4.5.ebuild
deleted file mode 100644
index 44a083d6d144..000000000000
--- a/dev-ruby/test-unit/test-unit-2.4.5.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.5.ebuild,v 1.1 2012/01/28 11:13:14 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 doc" "( dev-ruby/redcloth )"
-USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 doc" "( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}