summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-09 21:04:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-09 21:04:37 +0000
commited21617a2d4bf3c50497c55f3f01c4da993099e7 (patch)
tree189361cdb6ad67eb3f06bd01e453982e413b88df /dev-ruby/test-unit
parentAdd ~arm (diff)
downloadgentoo-2-ed21617a2d4bf3c50497c55f3f01c4da993099e7.tar.gz
gentoo-2-ed21617a2d4bf3c50497c55f3f01c4da993099e7.tar.bz2
gentoo-2-ed21617a2d4bf3c50497c55f3f01c4da993099e7.zip
Version bump, enable doc generation, wrap the testrb command as testrb2 (to avoid collisions).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog11
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.6.ebuild47
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 5c664b3e25f0..109d9a180fa5 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/test-unit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.13 2009/12/20 22:28:28 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.14 2010/01/09 21:04:37 flameeyes Exp $
+
+*test-unit-2.0.6 (09 Jan 2010)
+
+ 09 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +test-unit-2.0.6.ebuild:
+ Version bump, enable doc generation, wrap the testrb command as testrb2
+ (to avoid collisions).
20 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
-test-unit-2.0.2-r1.ebuild, -test-unit-2.0.3.ebuild,
diff --git a/dev-ruby/test-unit/test-unit-2.0.6.ebuild b/dev-ruby/test-unit/test-unit-2.0.6.ebuild
new file mode 100644
index 000000000000..fda29d719ba3
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.6.ebuild,v 1.1 2010/01/09 21:04:37 flameeyes Exp $
+
+EAPI=2
+# One test fails on jruby, might be a jruby bug
+# When enabled on ruby18 it breaks too many things, so don't enable it for that just yet
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend doc dev-ruby/hoe
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_intall() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bint/testrb2
+}