summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-05 20:52:23 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-05 20:52:23 +0000
commite20b3fea514283280132275e3e67fb7505c8fd37 (patch)
tree641ae4feb8c083b6b10d0f6efce4b2ba3b8dc87e /dev-ruby/test-unit
parentConvert ebuild to python-single-r1, bug #459984. (diff)
downloadgentoo-2-e20b3fea514283280132275e3e67fb7505c8fd37.tar.gz
gentoo-2-e20b3fea514283280132275e3e67fb7505c8fd37.tar.bz2
gentoo-2-e20b3fea514283280132275e3e67fb7505c8fd37.zip
Cleanup old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog6
-rw-r--r--dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild44
-rw-r--r--dev-ruby/test-unit/test-unit-2.4.8.ebuild46
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.5.ebuild64
4 files changed, 5 insertions, 155 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 156e8e9229f7..32594583cfc7 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.95 2014/02/24 01:14:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.96 2014/03/05 20:52:23 mrueg Exp $
+
+ 05 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -test-unit-2.1.2-r1.ebuild,
+ -test-unit-2.4.8.ebuild, -test-unit-2.5.5.ebuild:
+ Cleanup old.
24 Feb 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org>
test-unit-2.5.5-r1.ebuild:
diff --git a/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild b/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild
deleted file mode 100644
index 43c242b69df3..000000000000
--- a/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild,v 1.6 2012/10/28 17:34:46 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/rdoc )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha amd64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.4.8.ebuild b/dev-ruby/test-unit/test-unit-2.4.8.ebuild
deleted file mode 100644
index 74bce2c00cd3..000000000000
--- a/dev-ruby/test-unit/test-unit-2.4.8.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.4.8.ebuild,v 1.7 2012/10/28 17:34:46 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-# Disable default binwraps
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="alpha amd64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-all_ruby_compile() {
- all_fakegem_compile
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
- # rdoc-2* series.
- ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.5.5.ebuild b/dev-ruby/test-unit/test-unit-2.5.5.ebuild
deleted file mode 100644
index 6d739bff3eef..000000000000
--- a/dev-ruby/test-unit/test-unit-2.5.5.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.5.ebuild,v 1.1 2013/07/09 05:44:36 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Avoid tests with slightly different output for jruby
- sed -i -e '/test_assert_nothing_thrown/,/^ end/ s:^:#:' \
- -e '/test_assert_throw/,/^ end/ s:^:#:' test/test-assertions.rb || die
- # And fix missing testunit exposed by it
- sed -i -e "9irequire 'testunit-test-util'" test/test-assertions.rb || die
- ;;
- esac
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb testrb-2
-}