summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-09 05:44:36 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-09 05:44:36 +0000
commitc2b64644b37529d92b74bf9a99d6f120a50724c5 (patch)
tree4cc574d13e7f168c65bc91b0c15648b282cac1b7 /dev-ruby/test-unit
parentVersion bump wrt #474550 (diff)
downloadgentoo-2-c2b64644b37529d92b74bf9a99d6f120a50724c5.tar.gz
gentoo-2-c2b64644b37529d92b74bf9a99d6f120a50724c5.tar.bz2
gentoo-2-c2b64644b37529d92b74bf9a99d6f120a50724c5.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog7
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.5.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 5d0d17882e0b..053e842e7d56 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.80 2013/07/07 15:19:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.81 2013/07/09 05:44:36 graaff Exp $
+
+*test-unit-2.5.5 (09 Jul 2013)
+
+ 09 Jul 2013; Hans de Graaff <graaff@gentoo.org> +test-unit-2.5.5.ebuild:
+ Version bump.
07 Jul 2013; Agostino Sarubbo <ago@gentoo.org> test-unit-1.2.3.ebuild:
Stable for ia64, wrt bug #472910
diff --git a/dev-ruby/test-unit/test-unit-2.5.5.ebuild b/dev-ruby/test-unit/test-unit-2.5.5.ebuild
new file mode 100644
index 000000000000..6d739bff3eef
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.5.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.5.ebuild,v 1.1 2013/07/09 05:44:36 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+# redcloth is also needed to build documentation, but not available for
+# jruby. Since we build documentation with the main ruby implementation
+# only we skip the dependency for jruby in this roundabout way, assuming
+# that jruby won't be the main ruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid tests with slightly different output for jruby
+ sed -i -e '/test_assert_nothing_thrown/,/^ end/ s:^:#:' \
+ -e '/test_assert_throw/,/^ end/ s:^:#:' test/test-assertions.rb || die
+ # And fix missing testunit exposed by it
+ sed -i -e "9irequire 'testunit-test-util'" test/test-assertions.rb || die
+ ;;
+ esac
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb testrb-2
+}