summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-20 18:59:31 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-20 18:59:31 +0000
commitab9ca6a66705bdd0d7fe207987789ec0053637c4 (patch)
tree3a134239e5ab1bf8b6c0e7986531df38dbf10252 /dev-ruby/test-unit
parentRemove dev-ruby/test-unit mask. Let the tinderbox find the remaining problems... (diff)
downloadgentoo-2-ab9ca6a66705bdd0d7fe207987789ec0053637c4.tar.gz
gentoo-2-ab9ca6a66705bdd0d7fe207987789ec0053637c4.tar.bz2
gentoo-2-ab9ca6a66705bdd0d7fe207987789ec0053637c4.zip
Add ~amd64 keyword.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog12
-rw-r--r--dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch32
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.9.ebuild50
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index e43f6b1e815a..99f94a6b8aa4 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.18 2010/05/22 16:01:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.19 2010/06/20 18:59:31 graaff Exp $
+
+ 20 Jun 2010; Hans de Graaff <graaff@gentoo.org> +test-unit-2.0.9.ebuild,
+ +files/test-unit-2.0.9-disable-tests.patch:
+ Add ~amd64 keyword.
+
+*test-unit-2.0.9 (20 Jun 2010)
+
+ 20 Jun 2010; Hans de Graaff <graaff@gentoo.org> +test-unit-2.0.9.ebuild,
+ +files/test-unit-2.0.9-disable-tests.patch:
+ Version bump.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
test-unit-1.2.3.ebuild, test-unit-2.0.7.ebuild:
diff --git a/dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch b/dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch
new file mode 100644
index 000000000000..d6dd98fb75e2
--- /dev/null
+++ b/dev-ruby/test-unit/files/test-unit-2.0.9-disable-tests.patch
@@ -0,0 +1,32 @@
+--- test/test_assertions.rb.~1~ 2010-05-24 06:46:35.000000000 +0200
++++ test/test_assertions.rb 2010-06-20 20:49:19.344683987 +0200
+@@ -837,12 +837,6 @@
+ assert_in_delta(0.5, 0.4, 0.05, "message")
+ }
+ object = Object.new
+- check_fails("The arguments must respond to to_f; " +
+- "the first float did not.\n" +
+- "<#{object.inspect}>.respond_to?(:to_f) expected\n" +
+- "(Class: <Object>)") {
+- assert_in_delta(object, 0.4, 0.1)
+- }
+ check_fails("The delta should not be negative.\n" +
+ "<-0.1> expected to be\n>=\n<0.0>.") {
+ assert_in_delta(0.5, 0.4, -0.1, "message")
+@@ -1142,16 +1136,6 @@
+ "<#{object.method(:original_method).inspect}> expected") do
+ assert_alias_method(object, :other, :original_method)
+ end
+-
+- check_fails("<#{object.inspect}>.nonexistent doesn't exist\n" +
+- "(Class: <Object>)") do
+- assert_alias_method(object, :nonexistent, :original_method)
+- end
+-
+- check_fails("<#{object.inspect}>.nonexistent doesn't exist\n" +
+- "(Class: <Object>)") do
+- assert_alias_method(object, :alias_method, :nonexistent)
+- end
+ end
+
+ private
diff --git a/dev-ruby/test-unit/test-unit-2.0.9.ebuild b/dev-ruby/test-unit/test-unit-2.0.9.ebuild
new file mode 100644
index 000000000000..0c5d6f74a930
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.0.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.9.ebuild,v 1.1 2010/06/20 18:59:31 graaff Exp $
+
+EAPI=2
+# One test fails on jruby, might be a jruby bug
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Two tests for jruby currently fail. This has been reported upstream:
+# http://rubyforge.org/tracker/index.php?group_id=5650&atid=21856
+RUBY_PATCHES=( "${P}-disable-tests.patch" )
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_intall() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bint/testrb2
+}