summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-01-23 07:30:28 +0000
committerHans de Graaff <graaff@gentoo.org>2013-01-23 07:30:28 +0000
commit67f847585bee195483854fe10a8ebbd3c75cc089 (patch)
tree7019dbbfd81d96ba8efe00d6e01bde9682d29f9d /dev-ruby/test-unit
parentdev-util/nvidia-cuda-sdk: Fix last bit of bad deletion practise (diff)
downloadgentoo-2-67f847585bee195483854fe10a8ebbd3c75cc089.tar.gz
gentoo-2-67f847585bee195483854fe10a8ebbd3c75cc089.tar.bz2
gentoo-2-67f847585bee195483854fe10a8ebbd3c75cc089.zip
Cleanup.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog6
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.1-r1.ebuild52
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.2.ebuild52
3 files changed, 5 insertions, 105 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index e1279dd74c06..31a89c6f1509 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.75 2013/01/21 16:00:31 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.76 2013/01/23 07:30:28 graaff Exp $
+
+ 23 Jan 2013; Hans de Graaff <graaff@gentoo.org> -test-unit-2.5.1-r1.ebuild,
+ -test-unit-2.5.2.ebuild:
+ Cleanup.
21 Jan 2013; Agostino Sarubbo <ago@gentoo.org> test-unit-2.5.3.ebuild:
Stable for sparc, wrt bug #449558
diff --git a/dev-ruby/test-unit/test-unit-2.5.1-r1.ebuild b/dev-ruby/test-unit/test-unit-2.5.1-r1.ebuild
deleted file mode 100644
index 09af9285f6a4..000000000000
--- a/dev-ruby/test-unit/test-unit-2.5.1-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.1-r1.ebuild,v 1.2 2012/10/28 17:34:47 armin76 Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb testrb-2
-}
diff --git a/dev-ruby/test-unit/test-unit-2.5.2.ebuild b/dev-ruby/test-unit/test-unit-2.5.2.ebuild
deleted file mode 100644
index 67a51dc0d1a8..000000000000
--- a/dev-ruby/test-unit/test-unit-2.5.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.2.ebuild,v 1.2 2012/10/28 17:34:47 armin76 Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
-
-inherit ruby-fakegem
-
-ruby_add_bdepend "doc? ( dev-ruby/yard )"
-# redcloth is also needed to build documentation, but not available for
-# jruby. Since we build documentation with the main ruby implementation
-# only we skip the dependency for jruby in this roundabout way, assuming
-# that jruby won't be the main ruby.
-USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-
-LICENSE="Ruby"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb testrb-2
-}