summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-01-18 09:51:56 +0000
committerHans de Graaff <graaff@gentoo.org>2014-01-18 09:51:56 +0000
commit54a548dcce94eb254a44de52125acf69012d832c (patch)
treeafebe88158e6e513a9ca85af839d0909151aefa1 /dev-ruby/test-unit
parentAdd default console for arm64. (diff)
downloadgentoo-2-54a548dcce94eb254a44de52125acf69012d832c.tar.gz
gentoo-2-54a548dcce94eb254a44de52125acf69012d832c.tar.bz2
gentoo-2-54a548dcce94eb254a44de52125acf69012d832c.zip
Add ruby21.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog9
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 6cdbf4fa243b..4a1e7ab7efac 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.89 2013/12/26 16:09:02 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.90 2014/01/18 09:51:56 graaff Exp $
+
+*test-unit-2.5.5-r2 (10 Jan 2014)
+
+ 10 Jan 2014; Hans de Graaff <graaff@gentoo.org> +test-unit-2.5.5-r2.ebuild:
+ Add ruby21.
26 Dec 2013; Markus Meier <maekke@gentoo.org> test-unit-2.5.3.ebuild:
arm stable, bug #493780
diff --git a/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild b/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild
new file mode 100644
index 000000000000..dc911cda1223
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild,v 1.1 2014/01/18 09:51:56 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
+
+inherit ruby-fakegem
+
+# Assume for now that ruby21 is not eselected yet and only depend on
+# yard for the other ruby implementations. Without this assumption
+# bootstrapping ruby21 won't be possible due to the yard dependency
+# tree.
+USE_RUBY="${USE_RUBY/ruby20 ruby21/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
+# redcloth is also needed to build documentation, but not available for
+# jruby. Since we build documentation with the main ruby implementation
+# only we skip the dependency for jruby in this roundabout way, assuming
+# that jruby won't be the main ruby.
+USE_RUBY="${USE_RUBY/ruby20 ruby21 jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid tests with slightly different output for jruby
+ sed -i -e '/test_assert_nothing_thrown/,/^ end/ s:^:#:' \
+ -e '/test_assert_throw/,/^ end/ s:^:#:' test/test-assertions.rb || die
+ # And fix missing testunit exposed by it
+ sed -i -e "9irequire 'testunit-test-util'" test/test-assertions.rb || die
+ ;;
+ esac
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb testrb-2
+}