summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 17:42:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 17:42:57 +0000
commitb85434c14320a934070a6c9af41b9c29e68604ed (patch)
tree69f2db500722362c10761353c282cc40c30a74a5 /dev-ruby/termcolor
parentRaise glib dependency per bug #420331 (diff)
downloadgentoo-2-b85434c14320a934070a6c9af41b9c29e68604ed.tar.gz
gentoo-2-b85434c14320a934070a6c9af41b9c29e68604ed.tar.bz2
gentoo-2-b85434c14320a934070a6c9af41b9c29e68604ed.zip
Remove old; bump to EAPI 4, use the new rspec recipe for tests; remove mandatory dependency over rspec:0.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/termcolor')
-rw-r--r--dev-ruby/termcolor/ChangeLog7
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.0.ebuild29
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.1.ebuild12
3 files changed, 10 insertions, 38 deletions
diff --git a/dev-ruby/termcolor/ChangeLog b/dev-ruby/termcolor/ChangeLog
index eabb5e9a12be..37d0232c254f 100644
--- a/dev-ruby/termcolor/ChangeLog
+++ b/dev-ruby/termcolor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/termcolor
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.4 2012/07/14 07:12:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/ChangeLog,v 1.5 2012/08/13 17:42:57 flameeyes Exp $
+
+ 13 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> -termcolor-1.2.0.ebuild,
+ termcolor-1.2.1.ebuild:
+ Remove old; bump to EAPI 4, use the new rspec recipe for tests; remove
+ mandatory dependency over rspec:0.
14 Jul 2012; Hans de Graaff <graaff@gentoo.org> termcolor-1.2.1.ebuild,
+files/termcolor-1.2.1-fix-spec.patch:
diff --git a/dev-ruby/termcolor/termcolor-1.2.0.ebuild b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
deleted file mode 100644
index b92f29ceaf4d..000000000000
--- a/dev-ruby/termcolor/termcolor-1.2.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.0.ebuild,v 1.3 2012/07/08 21:46:13 naota Exp $
-
-EAPI="2"
-#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
-HOMEPAGE="http://termcolor.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_bdepend "dev-ruby/rspec:0"
-ruby_add_rdepend ">=dev-ruby/highline-1.5.0"
-
-each_ruby_test() {
- ${RUBY} -S spec spec || die
-}
diff --git a/dev-ruby/termcolor/termcolor-1.2.1.ebuild b/dev-ruby/termcolor/termcolor-1.2.1.ebuild
index d96c6092dd68..631f65dce7e4 100644
--- a/dev-ruby/termcolor/termcolor-1.2.1.ebuild
+++ b/dev-ruby/termcolor/termcolor-1.2.1.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.1.ebuild,v 1.2 2012/07/14 07:12:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/termcolor/termcolor-1.2.1.ebuild,v 1.3 2012/08/13 17:42:57 flameeyes Exp $
+
+EAPI=4
-EAPI="2"
#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
USE_RUBY="ruby18 ruby19 ree18"
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
@@ -23,9 +24,4 @@ IUSE=""
RUBY_PATCHES=( ${P}-fix-spec.patch )
-ruby_add_bdepend "dev-ruby/rspec:0"
ruby_add_rdepend ">=dev-ruby/highline-1.5.0"
-
-each_ruby_test() {
- ${RUBY} -S spec spec || die
-}