summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-06 08:48:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-06 08:48:37 +0000
commit1a772f96ae0065e186a5ae6159f78cc0a5cb3401 (patch)
tree55855afd20c7121717dee75201bd9fa7cbf9e9d1 /dev-ruby/storable
parentVersion bump. Drop broken version. (diff)
downloadgentoo-2-1a772f96ae0065e186a5ae6159f78cc0a5cb3401.tar.gz
gentoo-2-1a772f96ae0065e186a5ae6159f78cc0a5cb3401.tar.bz2
gentoo-2-1a772f96ae0065e186a5ae6159f78cc0a5cb3401.zip
Add patch to fix rudy.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/storable')
-rw-r--r--dev-ruby/storable/ChangeLog9
-rw-r--r--dev-ruby/storable/files/storable-0.7.1-emptysymbol.patch30
-rw-r--r--dev-ruby/storable/storable-0.7.1-r1.ebuild (renamed from dev-ruby/storable/storable-0.7.1.ebuild)4
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index efdb382ee64e..f63bac5e5441 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.5 2010/04/06 08:09:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.6 2010/04/06 08:48:36 flameeyes Exp $
+
+*storable-0.7.1-r1 (06 Apr 2010)
+
+ 06 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -storable-0.7.1.ebuild, +storable-0.7.1-r1.ebuild,
+ +files/storable-0.7.1-emptysymbol.patch:
+ Add patch to fix rudy.
*storable-0.7.1 (06 Apr 2010)
diff --git a/dev-ruby/storable/files/storable-0.7.1-emptysymbol.patch b/dev-ruby/storable/files/storable-0.7.1-emptysymbol.patch
new file mode 100644
index 000000000000..eb036ecfb15c
--- /dev/null
+++ b/dev-ruby/storable/files/storable-0.7.1-emptysymbol.patch
@@ -0,0 +1,30 @@
+From 2e458688a077412bb1d050f5e9ca1edeb8d89bb0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
+Date: Tue, 6 Apr 2010 10:31:24 +0200
+Subject: [PATCH] Handle empty symbols alike to the old Storable 0.6.4.
+
+Without this, rudy 0.9.8 aborts for me with:
+
+ERROR (ArgumentError): interning empty string
+
+because there it tries to create a symbol from an empty string.
+---
+ lib/storable.rb | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/lib/storable.rb b/lib/storable.rb
+index 45a4d34..9d7c958 100644
+--- a/lib/storable.rb
++++ b/lib/storable.rb
+@@ -178,7 +178,7 @@ class Storable
+
+ next if value_orig.nil?
+
+- if ftype == String && value_orig.to_s.empty?
++ if ( ftype == String or ftype == Symbol ) && value_orig.to_s.empty?
+ value = ''
+ elsif ftype == Array
+ value = Array === value_orig ? value_orig : [value_orig]
+--
+1.7.0.4
+
diff --git a/dev-ruby/storable/storable-0.7.1.ebuild b/dev-ruby/storable/storable-0.7.1-r1.ebuild
index b67382904ad8..c0dffe37a701 100644
--- a/dev-ruby/storable/storable-0.7.1.ebuild
+++ b/dev-ruby/storable/storable-0.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.1.ebuild,v 1.1 2010/04/06 08:09:01 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.1-r1.ebuild,v 1.1 2010/04/06 08:48:36 flameeyes Exp $
EAPI=2
@@ -29,6 +29,8 @@ ruby_add_bdepend test dev-ruby/tryouts
all_ruby_prepare() {
mv bin examples || die
+
+ epatch "${FILESDIR}"/${P}-emptysymbol.patch
}
each_ruby_test() {