summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-28 00:30:37 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-28 00:30:37 +0000
commit067a013037f8e7cd6ddc644ff54d92b7cb6e7f91 (patch)
treeddb2beb3a35422db88ca8dbb360825ae52c6670d /dev-ruby/sqlite3
parentVersion bump. Add ruby21 target (diff)
downloadgentoo-2-067a013037f8e7cd6ddc644ff54d92b7cb6e7f91.tar.gz
gentoo-2-067a013037f8e7cd6ddc644ff54d92b7cb6e7f91.tar.bz2
gentoo-2-067a013037f8e7cd6ddc644ff54d92b7cb6e7f91.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/sqlite3')
-rw-r--r--dev-ruby/sqlite3/ChangeLog7
-rw-r--r--dev-ruby/sqlite3/sqlite3-1.3.9.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-ruby/sqlite3/ChangeLog b/dev-ruby/sqlite3/ChangeLog
index b40e1b6fc0c9..9cfacecc732f 100644
--- a/dev-ruby/sqlite3/ChangeLog
+++ b/dev-ruby/sqlite3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/sqlite3
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/ChangeLog,v 1.16 2014/02/25 08:08:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/ChangeLog,v 1.17 2014/02/28 00:30:37 mrueg Exp $
+
+*sqlite3-1.3.9 (28 Feb 2014)
+
+ 28 Feb 2014; Manuel Rüger <mrueg@gentoo.org> +sqlite3-1.3.9.ebuild:
+ Version bump.
25 Feb 2014; Hans de Graaff <graaff@gentoo.org> sqlite3-1.3.6.ebuild,
sqlite3-1.3.8-r1.ebuild:
diff --git a/dev-ruby/sqlite3/sqlite3-1.3.9.ebuild b/dev-ruby/sqlite3/sqlite3-1.3.9.ebuild
new file mode 100644
index 000000000000..6d6aac0ea7ff
--- /dev/null
+++ b/dev-ruby/sqlite3/sqlite3-1.3.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.9.ebuild,v 1.1 2014/02/28 00:30:37 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs faq"
+RUBY_FAKEGEM_DOCDIR="doc faq"
+RUBY_FAKEGEM_EXTRADOC="API_CHANGES.rdoc README.rdoc ChangeLog.cvs CHANGELOG.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An extension library to access a SQLite database from Ruby"
+HOMEPAGE="http://rubyforge.org/projects/sqlite-ruby/"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND+=" =dev-db/sqlite-3*"
+DEPEND+=" =dev-db/sqlite-3*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/hoe
+ doc? ( dev-ruby/redcloth )
+ test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ # We remove the vendor_sqlite3 rake task because it's used to
+ # bundle SQlite3 which we definitely don't want.
+ rm tasks/vendor_sqlite3.rake || die
+
+ # Remove license line from hoe to avoid depending on a newer
+ # version.
+ sed -i -e '/license/d' tasks/gem.rake || die
+
+ sed -i -e 's:, HOE.spec::' -e '/task :test/d' tasks/native.rake || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/sqlite3 extconf.rb || die
+}
+
+each_ruby_compile() {
+ # TODO: not sure what happens with jruby
+
+ emake -Cext/sqlite3 V=1
+ mv ext/sqlite3/sqlite3_native$(get_modname) lib/sqlite3/ || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # sqlite3 was called sqlite3-ruby before, so add a spec file that
+ # simply loads sqlite3 to make sure that old projects load correctly
+ # we don't even need to create a file to load this: the `require
+ # sqlite3` was already part of sqlite3-ruby requirements.
+ cat - <<EOF > "${T}/sqlite3-ruby.gemspec"
+# generated by ebuild
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/sqlite3/sqlite3-1.3.9.ebuild,v 1.1 2014/02/28 00:30:37 mrueg Exp $
+Gem::Specification.new do |s|
+ s.name = "sqlite3-ruby"
+ s.version = "${RUBY_FAKEGEM_VERSION}"
+ s.summary = "Fake gem to load sqlite3"
+ s.homepage = "${HOMEPAGE}"
+ s.specification_version = 3
+ s.add_runtime_dependency("${RUBY_FAKEGEM_NAME}", ["= ${RUBY_FAKEGEM_VERSION}"])
+end
+EOF
+ RUBY_FAKEGEM_NAME=sqlite3-ruby \
+ RUBY_FAKEGEM_GEMSPEC="${T}/sqlite3-ruby.gemspec" \
+ ruby_fakegem_install_gemspec
+}