summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-26 19:30:59 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-26 19:30:59 +0000
commit022c81919f9fb5c91ddf34e2ae5a0d82e35ee042 (patch)
tree94e2f65b556c35d4acba00914c13e72cc570f010 /dev-ruby/shoulda-context
parentStable for HPPA too. (diff)
downloadgentoo-2-022c81919f9fb5c91ddf34e2ae5a0d82e35ee042.tar.gz
gentoo-2-022c81919f9fb5c91ddf34e2ae5a0d82e35ee042.tar.bz2
gentoo-2-022c81919f9fb5c91ddf34e2ae5a0d82e35ee042.zip
Initial import. New dependency for newer shoulda versions.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/ChangeLog10
-rw-r--r--dev-ruby/shoulda-context/metadata.xml5
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.1.4.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/ChangeLog b/dev-ruby/shoulda-context/ChangeLog
new file mode 100644
index 000000000000..32943e127a5b
--- /dev/null
+++ b/dev-ruby/shoulda-context/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/shoulda-context
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda-context/ChangeLog,v 1.1 2013/11/26 19:30:59 graaff Exp $
+
+*shoulda-context-1.1.4 (26 Nov 2013)
+
+ 26 Nov 2013; Hans de Graaff <graaff@gentoo.org>
+ +shoulda-context-1.1.4.ebuild, +metadata.xml:
+ Initial import. New dependency for newer shoulda versions.
+
diff --git a/dev-ruby/shoulda-context/metadata.xml b/dev-ruby/shoulda-context/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/shoulda-context/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.1.4.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.1.4.ebuild
new file mode 100644
index 000000000000..25a28982fa4a
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda-context/shoulda-context-1.1.4.ebuild,v 1.1 2013/11/26 19:30:59 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/mocha )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}