summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-12-01 20:19:37 +0000
committerAron Griffis <agriffis@gentoo.org>2003-12-01 20:19:37 +0000
commit84871937b7301409cf203cfae663d4fd8b05a5bd (patch)
treef1adb66b41f28a27f540ad3c788570502a1a75b4 /dev-ruby/rubymail/rubymail-0.15.ebuild
parentversion bump (diff)
downloadgentoo-2-84871937b7301409cf203cfae663d4fd8b05a5bd.tar.gz
gentoo-2-84871937b7301409cf203cfae663d4fd8b05a5bd.tar.bz2
gentoo-2-84871937b7301409cf203cfae663d4fd8b05a5bd.zip
version bump
Diffstat (limited to 'dev-ruby/rubymail/rubymail-0.15.ebuild')
-rw-r--r--dev-ruby/rubymail/rubymail-0.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rubymail/rubymail-0.15.ebuild b/dev-ruby/rubymail/rubymail-0.15.ebuild
new file mode 100644
index 000000000000..a46e20abf785
--- /dev/null
+++ b/dev-ruby/rubymail/rubymail-0.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubymail/rubymail-0.15.ebuild,v 1.1 2003/12/01 20:19:34 agriffis Exp $
+
+DESCRIPTION="A mail handling library for Ruby"
+HOMEPAGE="http://www.lickey.com/rubymail/"
+SRC_URI="http://www.lickey.com/rubymail/download/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lang/ruby-1.6"
+
+src_compile() {
+ ruby install.rb config --prefix=/usr || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+ dodoc NEWS NOTES README THANKS TODO
+ dohtml -r doc/*
+ cp -dr guide ${D}/usr/share/doc/${PF}
+}