summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-09-30 05:08:32 +0000
committerHans de Graaff <graaff@gentoo.org>2014-09-30 05:08:32 +0000
commit3e1dbde7c7ea2e4efdcf97160071d0d658fda3c7 (patch)
tree87de65510d22156605ac9a3e0da8e36453969ebd /dev-ruby/ruby_parser
parentnew package requestd by phajdan.jr in Bug #523180, required as a dep to suppo... (diff)
downloadgentoo-2-3e1dbde7c7ea2e4efdcf97160071d0d658fda3c7.tar.gz
gentoo-2-3e1dbde7c7ea2e4efdcf97160071d0d658fda3c7.tar.bz2
gentoo-2-3e1dbde7c7ea2e4efdcf97160071d0d658fda3c7.zip
Version bump.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ruby_parser')
-rw-r--r--dev-ruby/ruby_parser/ChangeLog7
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.6.3.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/ruby_parser/ChangeLog b/dev-ruby/ruby_parser/ChangeLog
index 2adef14ea747..0dfabf124c5c 100644
--- a/dev-ruby/ruby_parser/ChangeLog
+++ b/dev-ruby/ruby_parser/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby_parser
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.64 2014/08/05 16:00:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ChangeLog,v 1.65 2014/09/30 05:08:32 graaff Exp $
+
+*ruby_parser-3.6.3 (30 Sep 2014)
+
+ 30 Sep 2014; Hans de Graaff <graaff@gentoo.org> +ruby_parser-3.6.3.ebuild:
+ Version bump.
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> ruby_parser-2.3.1-r1.ebuild,
ruby_parser-3.1.3.ebuild, ruby_parser-3.6.1.ebuild, ruby_parser-3.6.2.ebuild:
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.6.3.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.6.3.ebuild
new file mode 100644
index 000000000000..2f98c9643ddd
--- /dev/null
+++ b/dev-ruby/ruby_parser/ruby_parser-3.6.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby_parser/ruby_parser-3.6.3.ebuild,v 1.1 2014/09/30 05:08:32 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby parser written in pure ruby"
+HOMEPAGE="https://github.com/seattlerb/ruby_parser"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/sexp_processor-4.1:4
+ !<dev-ruby/ruby_parser-2.3.1-r1"
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-4.3 )"
+
+all_ruby_prepare() {
+ # Remove reference to perforce method that is not in a released
+ # version of hoe-seattlerb.
+ #sed -i -e '/perforce/d' Rakefile || die
+ sed -i -e '/license/d' Rakefile || die
+ sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Disable tests failing on jruby related to //n regexp
+ # https://github.com/seattlerb/ruby_parser/issues/117
+ rm test/test_ruby_parser.rb || die
+ ;;
+ esac
+}