summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-30 04:21:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-30 04:21:26 +0000
commit78dd5dcc9d45df475e8b5fb2f5f9de3afa997bc1 (patch)
tree234917a0d1db0b5d2b0ec697a729c553e628609b /dev-ruby/ruby-tcpwrap
parentFix whitespace. (diff)
downloadgentoo-2-78dd5dcc9d45df475e8b5fb2f5f9de3afa997bc1.tar.gz
gentoo-2-78dd5dcc9d45df475e8b5fb2f5f9de3afa997bc1.tar.bz2
gentoo-2-78dd5dcc9d45df475e8b5fb2f5f9de3afa997bc1.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby-tcpwrap')
-rw-r--r--dev-ruby/ruby-tcpwrap/ChangeLog9
-rw-r--r--dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r2.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/dev-ruby/ruby-tcpwrap/ChangeLog b/dev-ruby/ruby-tcpwrap/ChangeLog
index 0eaa9ec4c2d5..aa151a25ed05 100644
--- a/dev-ruby/ruby-tcpwrap/ChangeLog
+++ b/dev-ruby/ruby-tcpwrap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-tcpwrap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ChangeLog,v 1.21 2012/09/22 06:24:11 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ChangeLog,v 1.22 2013/10/30 04:21:26 mrueg Exp $
+
+*ruby-tcpwrap-0.6-r2 (30 Oct 2013)
+
+ 30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +ruby-tcpwrap-0.6-r2.ebuild:
+ Add ruby20 target.
22 Sep 2012; Hans de Graaff <graaff@gentoo.org> -ruby-tcpwrap-0.6.ebuild:
Cleanup.
diff --git a/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r2.ebuild b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r2.ebuild
new file mode 100644
index 000000000000..2f4ceb8dc57f
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.6-r2.ebuild,v 1.1 2013/10/30 04:21:26 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+inherit ruby-ng
+
+DESCRIPTION="A TCP wrappers library for Ruby"
+HOMEPAGE="http://raa.ruby-lang.org/list.rhtml?name=ruby-tcpwrap"
+SRC_URI="http://shugo.net/archive/ruby-tcpwrap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" net-libs/libident
+ sys-apps/tcp-wrappers"
+
+RDEPEND+=" net-libs/libident
+ sys-apps/tcp-wrappers"
+
+RUBY_S="${PN}"
+RUBY_PATCHES=( "${P}-ruby19.patch" )
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ # We have injected --no-undefined in Ruby as a safety precaution
+ # against broken ebuilds, but the Ruby-Gnome bindings
+ # unfortunately rely on the lazy load of other extensions; see bug
+ # #320545.
+ find . -name Makefile -print0 | xargs -0 \
+ sed -i -e 's:-Wl,--no-undefined ::' || die "--no-undefined removal failed"
+
+ emake V=1
+}
+
+each_ruby_install() {
+ emake DESTDIR="${D}" install V=1
+}
+
+all_ruby_install() {
+ dodoc README*
+ dohtml doc/*
+
+ docinto sample
+ dodoc sample/*
+}