summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 17:39:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-29 17:39:22 +0000
commit20202ad04eee08314a463eb93a1f667586743b2b (patch)
tree0dc91201561698e1dff773405c5723a2e0c4f8f1 /dev-ruby/ruby-shout
parentno more upstream homepage (diff)
downloadgentoo-2-20202ad04eee08314a463eb93a1f667586743b2b.tar.gz
gentoo-2-20202ad04eee08314a463eb93a1f667586743b2b.tar.bz2
gentoo-2-20202ad04eee08314a463eb93a1f667586743b2b.zip
Remove support for Ruby 1.9 (patch left undefined symbols), simplify ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-shout')
-rw-r--r--dev-ruby/ruby-shout/ChangeLog7
-rw-r--r--dev-ruby/ruby-shout/files/ruby-shout-2.1+ruby-1.9.patch116
-rw-r--r--dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild26
3 files changed, 15 insertions, 134 deletions
diff --git a/dev-ruby/ruby-shout/ChangeLog b/dev-ruby/ruby-shout/ChangeLog
index a14b2d6d424c..389c5bcebe3b 100644
--- a/dev-ruby/ruby-shout/ChangeLog
+++ b/dev-ruby/ruby-shout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-shout
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shout/ChangeLog,v 1.12 2010/01/29 12:38:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shout/ChangeLog,v 1.13 2010/07/29 17:39:22 flameeyes Exp $
+
+ 29 Jul 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ ruby-shout-2.1-r2.ebuild, -files/ruby-shout-2.1+ruby-1.9.patch:
+ Remove support for Ruby 1.9 (patch left undefined symbols), simplify
+ ebuild.
29 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-shout-2.1-r2.ebuild:
diff --git a/dev-ruby/ruby-shout/files/ruby-shout-2.1+ruby-1.9.patch b/dev-ruby/ruby-shout/files/ruby-shout-2.1+ruby-1.9.patch
deleted file mode 100644
index f2e98a029aef..000000000000
--- a/dev-ruby/ruby-shout/files/ruby-shout-2.1+ruby-1.9.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-diff -ru a/ext/shout.c b/ext/shout.c
---- a/ext/shout.c 1970-01-01 01:00:00.000000000 +0100
-+++ b/ext/shout.c 2008-10-06 12:28:08.000000000 +0200
-@@ -40,6 +40,11 @@
-
- #define DEFAULT_MOUNTPOINT "/default"
-
-+#ifndef RSTRING_LEN
-+#define RSTRING_LEN(str) RSTRING(str)->len
-+#define RSTRING_PTR(str) RSTRING(str)->ptr
-+#endif
-+
- /*
- ----------------- ShoutError --------------------
- */
-@@ -233,8 +238,8 @@
- GET_SC(self, s);
-
- Check_SafeStr(to_send);
-- err = shout_send(s->conn, (unsigned char *) (RSTRING(to_send)->ptr),
-- RSTRING(to_send)->len);
-+ err = shout_send(s->conn, (unsigned char *) (RSTRING_PTR(to_send)),
-+ RSTRING_LEN(to_send));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -409,7 +414,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_host(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_host(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -435,7 +440,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_user(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_user(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -448,7 +453,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_password(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_password(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -495,7 +500,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_mount(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_mount(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -509,7 +514,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_dumpfile(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_dumpfile(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -523,7 +528,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_agent(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_agent(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -554,7 +559,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_name(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_name(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -567,7 +572,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_url(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_url(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -580,7 +585,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_genre(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_genre(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
-@@ -593,7 +598,7 @@
- shout_connection *s; GET_SC(self, s);
-
- Check_Type(value, T_STRING);
-- err = shout_set_description(s->conn, RSTRING(value)->ptr);
-+ err = shout_set_description(s->conn, RSTRING_PTR(value));
- if(err != SHOUTERR_SUCCESS) {
- raise_shout_error(s->conn);
- }
diff --git a/dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild b/dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild
index 0566e15357a8..f32f63a8b8b1 100644
--- a/dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild
+++ b/dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild,v 1.2 2010/01/29 12:38:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-shout/ruby-shout-2.1-r2.ebuild,v 1.3 2010/07/29 17:39:22 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_TASK_DOC=""
@@ -21,29 +21,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=media-libs/libshout-2.0"
-DEPEND="${RDEPEND}"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}+ruby-1.9.patch
-}
+RDEPEND="${RDEPEND}
+ >=media-libs/libshout-2.0"
+DEPEND="${DEPEND}
+ >=media-libs/libshout-2.0"
each_ruby_configure() {
- pushd ext &>/dev/null
- ${RUBY} extconf.rb || die "extconf failed"
- popd &>/dev/null
+ ${RUBY} -Cext extconf.rb || die "extconf failed"
}
each_ruby_compile() {
- pushd ext &>/dev/null
- emake || die "emake failed"
- popd &>/dev/null
+ emake -C ext || die "emake failed"
}
each_ruby_install() {
each_fakegem_install
- pushd ext &>/dev/null
- ruby_fakegem_newins ${PN#ruby-}.so lib/${PN#ruby-}.so
- popd &>/dev/null
+ ruby_fakegem_newins ext/${PN#ruby-}.so lib/${PN#ruby-}.so
}