summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-17 06:14:25 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-17 06:14:25 +0000
commita5e906bbc58a1896d13e0f15cbad6c485c10e6db (patch)
tree7d63a1250904af423aaab30189e9a053fd63ff65 /dev-ruby/ruby-prof
parentVersion bump. (diff)
downloadgentoo-2-a5e906bbc58a1896d13e0f15cbad6c485c10e6db.tar.gz
gentoo-2-a5e906bbc58a1896d13e0f15cbad6c485c10e6db.tar.bz2
gentoo-2-a5e906bbc58a1896d13e0f15cbad6c485c10e6db.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog9
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.12.2.ebuild65
2 files changed, 72 insertions, 2 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 255e1aba7f3a..5893723afb29 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-prof
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.34 2012/08/14 18:53:33 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.35 2013/04/17 06:14:25 graaff Exp $
+
+*ruby-prof-0.12.2 (17 Apr 2013)
+
+ 17 Apr 2013; Hans de Graaff <graaff@gentoo.org> +ruby-prof-0.12.2.ebuild:
+ Version bump.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata.xml so that it's the same as most other packages.
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.12.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.12.2.ebuild
new file mode 100644
index 000000000000..6ae3cbe99b76
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.12.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.12.2.ebuild,v 1.1 2013/04/17 06:14:25 graaff Exp $
+
+EAPI=5
+
+# jruby → not compatible, since it uses an extension, but there is a bug
+# open for it: https://github.com/rdp/ruby-prof/issues/36
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # The thread testing in 0.8.1 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution. The problem is that it's _very_
+ # timing-dependent.
+ rm "${S}"/test/thread_test.rb \
+ || die "unable to remove broken test unit"
+ sed -i -e '/thread_test/d' \
+ test/test_suite.rb || die "unable to remove broken test reference"
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/ruby_prof || die "build failed"
+
+ mkdir lib/ruby_prof || die "unable to create directory for shared object"
+ cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+}
+
+each_ruby_test() {
+ ${RUBY} test/test_suite.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples ; do
+ docinto "$dir"
+ dodoc -r "$dir"/*
+ done
+}