summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 01:44:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 01:44:03 +0000
commit91884abdef5b09918d54327112b348a9e77de7c2 (patch)
tree4f2695900bca73b39944cae189ab28adf5db09fb /dev-ruby/ruby-prof
parentEnable jruby support. (diff)
downloadgentoo-2-91884abdef5b09918d54327112b348a9e77de7c2.tar.gz
gentoo-2-91884abdef5b09918d54327112b348a9e77de7c2.tar.bz2
gentoo-2-91884abdef5b09918d54327112b348a9e77de7c2.zip
Remove old versions.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog6
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.7.ebuild54
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.9.ebuild54
3 files changed, 5 insertions, 109 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 7db2a1597e20..95d6bbbc2fa7 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.21 2010/01/23 00:40:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.22 2010/01/28 01:44:03 flameeyes Exp $
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -ruby-prof-0.7.7.ebuild, -ruby-prof-0.7.9.ebuild:
+ Remove old versions.
*ruby-prof-0.7.10 (23 Jan 2010)
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.7.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.7.ebuild
deleted file mode 100644
index 1167097a5e5e..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.7.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.7.ebuild,v 1.1 2010/01/15 01:01:07 flameeyes Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend test virtual/ruby-test-unit
-
-all_ruby_prepare() {
- # The thread testing in 0.7.5 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
-}
-
-each_ruby_compile() {
- pushd ext
- ${RUBY} extconf.rb || die "extconf.rb failed"
- # gem ships with prebuild files
- emake clean || die "clean failed"
- emake || die "build failed"
- popd
-
- cp ext/*.so lib || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.9.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.9.ebuild
deleted file mode 100644
index dc852fc17f9a..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.7.9.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.9.ebuild,v 1.1 2010/01/16 13:42:08 flameeyes Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend test virtual/ruby-test-unit
-
-all_ruby_prepare() {
- # The thread testing in 0.7.5 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
-}
-
-each_ruby_compile() {
- pushd ext
- ${RUBY} extconf.rb || die "extconf.rb failed"
- # gem ships with prebuild files
- emake clean || die "clean failed"
- emake || die "build failed"
- popd
-
- cp ext/*.so lib || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}