summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-19 12:55:10 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-19 12:55:10 +0000
commit49124bb647351f2aa91ea491b4fa517243c6d3be (patch)
tree962fad2f61a098c7efa8c5b94c2e05b3742e7c09 /dev-ruby/ruby-prof
parentMoonlight is neither parallel build safe, bug #337960, upstream bug #640395. (diff)
downloadgentoo-2-49124bb647351f2aa91ea491b4fa517243c6d3be.tar.gz
gentoo-2-49124bb647351f2aa91ea491b4fa517243c6d3be.tar.bz2
gentoo-2-49124bb647351f2aa91ea491b4fa517243c6d3be.zip
Version bump with enhancements and bug fixes.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog7
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 5e885bfad1d2..982db5553962 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.28 2010/08/21 21:48:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.29 2010/09/19 12:55:10 graaff Exp $
+
+*ruby-prof-0.9.2 (19 Sep 2010)
+
+ 19 Sep 2010; Hans de Graaff <graaff@gentoo.org> +ruby-prof-0.9.2.ebuild:
+ Version bump with enhancements and bug fixes.
21 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-files/ruby-prof-0.7.2+glibc-2.8.patch, -ruby-prof-0.8.2.ebuild:
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild
new file mode 100644
index 000000000000..fd03ac65681d
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.9.2.ebuild,v 1.1 2010/09/19 12:55:10 graaff Exp $
+
+EAPI=2
+
+# jruby → not compatible, since it uses an extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ # The thread testing in 0.8.1 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution. The problem is that it's _very_
+ # timing-dependent.
+ rm "${S}"/test/thread_test.rb \
+ || die "unable to remove broken test unit"
+ sed -i -e '/thread_test/d' \
+ test/test_suite.rb || die "unable to remove broken test reference"
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # On ruby 1.9 this test fails badly, so we disable it
+ # until upstream can fix the related bug:
+ # http://redmine.ruby-lang.org/issues/show/2012
+ sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
+ test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
+ ;;
+ esac
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ # gem ships with prebuild files
+ emake -Cext/ruby_prof clean || die "clean failed"
+ emake -Cext/ruby_prof || die "build failed"
+
+ mkdir lib/ruby_prof || die "unable to create directory for shared object"
+ cp ext/ruby_prof/*$(get_modname) lib/ruby_prof || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples rails rails/example rails/environment; do
+ docinto "$dir"
+ dodoc "$dir"/* || die "dodoc $dir failed"
+ done
+}