summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-28 23:42:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-28 23:42:27 +0000
commit238249685d4bca66e243b10264d9d1bc8623dfe2 (patch)
tree2f2d6b570c66b4bb4f8388974def2ac1730bbb0d /dev-ruby/ruby-prof
parentamd64/x86 stable, bug #296591 (diff)
downloadgentoo-2-238249685d4bca66e243b10264d9d1bc8623dfe2.tar.gz
gentoo-2-238249685d4bca66e243b10264d9d1bc8623dfe2.tar.bz2
gentoo-2-238249685d4bca66e243b10264d9d1bc8623dfe2.zip
Version bump and port to fakegem.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/ChangeLog8
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.7.5.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 6b8f047e082f..5d6de6593c7d 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.15 2009/12/24 16:59:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.16 2009/12/28 23:42:27 flameeyes Exp $
+
+*ruby-prof-0.7.5 (28 Dec 2009)
+
+ 28 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ruby-prof-0.7.5.ebuild:
+ Version bump and port to fakegem.
24 Dec 2009; Hans de Graaff <graaff@gentoo.org> ruby-prof-0.7.3.ebuild:
Remove obsolete virtual/ruby dependency.
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.7.5.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.7.5.ebuild
new file mode 100644
index 000000000000..37e18ddb2bdb
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.7.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.7.5.ebuild,v 1.1 2009/12/28 23:42:27 flameeyes Exp $
+
+EAPI=2
+
+# ruby19 → not compatible as of 0.7.5 (upstream-provided information)
+# jruby → not compatible, since it uses an extension
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_EXTRADOC="README CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # The thread testing in 0.7.5 and earlier versions is broken, it
+ # has to be tested for the next versions, since upstream is
+ # looking for a solution. The problem is that it's _very_
+ # timing-dependent.
+ rm "${S}"/test/thread_test.rb \
+ || die "unable to remove broken test unit"
+ sed -i -e '/thread_test/d' \
+ test/test_suite.rb || die "unable to remove broken test reference"
+}
+
+each_ruby_compile() {
+ pushd ext
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+ # gem ships with prebuild files
+ emake clean || die "clean failed"
+ emake || die "build failed"
+ popd
+
+ cp ext/*.so lib || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples rails rails/example rails/environment; do
+ docinto "$dir"
+ dodoc "$dir"/* || die "dodoc $dir failed"
+ done
+}