summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-07-13 23:05:56 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-07-13 23:05:56 +0000
commit9089a4db0f44fae094154eadbbe80b3fa6de9ab1 (patch)
tree8b966c6101c839dd03991a6b5979fcba383cd38b /dev-ruby/ruby-postgres
parentAdding another dependency since the ebuild doesn't compile when either the ga... (diff)
downloadgentoo-2-9089a4db0f44fae094154eadbbe80b3fa6de9ab1.tar.gz
gentoo-2-9089a4db0f44fae094154eadbbe80b3fa6de9ab1.tar.bz2
gentoo-2-9089a4db0f44fae094154eadbbe80b3fa6de9ab1.zip
Version bump. See bug #177150.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'dev-ruby/ruby-postgres')
-rw-r--r--dev-ruby/ruby-postgres/ChangeLog8
-rw-r--r--dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.200604063
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20060406.ebuild25
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/ruby-postgres/ChangeLog b/dev-ruby/ruby-postgres/ChangeLog
index 6e3a56bce75c..fdd67cf1c7d0 100644
--- a/dev-ruby/ruby-postgres/ChangeLog
+++ b/dev-ruby/ruby-postgres/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-postgres
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.14 2007/03/15 03:52:32 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.15 2007/07/13 23:05:55 nichoj Exp $
+
+*ruby-postgres-0.7.1.20060406 (13 Jul 2007)
+
+ 13 Jul 2007; Joshua Nichols <nichoj@gentoo.org>
+ +ruby-postgres-0.7.1.20060406.ebuild:
+ Version bump. See bug #177150.
14 Mar 2007; Tom Gall <tgall@gentoo.org>
ruby-postgres-0.7.1.20051221-r1.ebuild:
diff --git a/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20060406 b/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20060406
new file mode 100644
index 000000000000..1910b8835144
--- /dev/null
+++ b/dev-ruby/ruby-postgres/files/digest-ruby-postgres-0.7.1.20060406
@@ -0,0 +1,3 @@
+MD5 810ccd6684e93c25ed7281d4f96b3839 ruby-postgres-0.7.1.2006.04.06.gem 46592
+RMD160 3577ffc3f44183510765c0a751b764f82e46aede ruby-postgres-0.7.1.2006.04.06.gem 46592
+SHA256 13f27bf37fe8c98c8775bc28225025996e0f72afb5fc574cd3fd8d0f6bf1b887 ruby-postgres-0.7.1.2006.04.06.gem 46592
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20060406.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20060406.ebuild
new file mode 100644
index 000000000000..a1fbc9876f94
--- /dev/null
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20060406.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.20060406.ebuild,v 1.1 2007/07/13 23:05:56 nichoj Exp $
+
+inherit ruby gems versionator
+
+# changes 0.7.1.20060406 to 0.7.1.2006.04.06
+
+# ideally, PV would have been this to start with, but can't change it now as
+# 0.7.1.20051221 > 0.7.1.2006.04.06.
+MY_PV="0.7.1.2006.04.06"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://ruby.scripting.ca/postgres"
+SRC_URI="http://gems.rubyforge.org/gems/${MY_P}.gem"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+USE_RUBY="ruby18"
+
+RDEPEND=">=dev-db/libpq-6.4"
+DEPEND="${RDEPEND}
+ >=dev-ruby/rubygems-0.9.0-r1"