summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-20 18:03:24 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-20 18:03:24 +0000
commit657485d8e280068780616b3b12f87e5b404e6340 (patch)
treef81ac50a04d6bc61b338146880c664bffa8109e7 /dev-ruby/ruby-postgres
parentamd64 stable wrt #322867 (diff)
downloadgentoo-2-657485d8e280068780616b3b12f87e5b404e6340.tar.gz
gentoo-2-657485d8e280068780616b3b12f87e5b404e6340.tar.bz2
gentoo-2-657485d8e280068780616b3b12f87e5b404e6340.zip
Convert to ruby-fakegem.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-postgres')
-rw-r--r--dev-ruby/ruby-postgres/ChangeLog8
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/ruby-postgres/ChangeLog b/dev-ruby/ruby-postgres/ChangeLog
index 65223284748e..b6285c2c7058 100644
--- a/dev-ruby/ruby-postgres/ChangeLog
+++ b/dev-ruby/ruby-postgres/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-postgres
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.25 2010/06/17 18:33:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.26 2010/06/20 18:03:24 graaff Exp $
+
+*ruby-postgres-0.7.9.20080128-r1 (20 Jun 2010)
+
+ 20 Jun 2010; Hans de Graaff <graaff@gentoo.org>
+ +ruby-postgres-0.7.9.20080128-r1.ebuild:
+ Convert to ruby-fakegem.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org>
ruby-postgres-0.7.1.ebuild, ruby-postgres-0.7.1.20060406.ebuild,
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r1.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r1.ebuild
new file mode 100644
index 000000000000..878504ea1afd
--- /dev/null
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r1.ebuild,v 1.1 2010/06/20 18:03:24 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Contributors README"
+
+inherit multilib ruby-fakegem versionator
+
+# changes 0.7.1.20060406 to 0.7.1.2006.04.06
+
+# ideally, PV would have been this to start with, but can't change it now as
+# 0.7.1.20051221 > 0.7.1.2006.04.06.
+MY_PV="0.7.9.2008.01.28"
+MY_PN="postgres"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://ruby.scripting.ca/postgres"
+SRC_URI="mirror://rubygems/${MY_P}.gem"
+LICENSE="GPL-2 Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-db/postgresql-base"
+DEPEND="${DEPEND} dev-db/postgresql-base"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+}
+
+each_ruby_install() {
+ mkdir lib || die
+ mv ext/postgres$(get_modname) lib/ || die
+
+ each_fakegem_install
+}