summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-02 16:34:56 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-02 16:34:56 +0000
commitb91d0977eb4a36d6750c58dd92dd86d092c517b4 (patch)
treeee187896782805d9ec75c62462fa5daa7e14859a /dev-ruby/ruby-odbc
parentversion bump (diff)
downloadgentoo-2-b91d0977eb4a36d6750c58dd92dd86d092c517b4.tar.gz
gentoo-2-b91d0977eb4a36d6750c58dd92dd86d092c517b4.tar.bz2
gentoo-2-b91d0977eb4a36d6750c58dd92dd86d092c517b4.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-odbc')
-rw-r--r--dev-ruby/ruby-odbc/ChangeLog7
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-ruby/ruby-odbc/ChangeLog b/dev-ruby/ruby-odbc/ChangeLog
index 945027d552a6..a924260d6710 100644
--- a/dev-ruby/ruby-odbc/ChangeLog
+++ b/dev-ruby/ruby-odbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-odbc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.26 2011/01/02 16:27:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.27 2011/01/02 16:34:56 graaff Exp $
+
+*ruby-odbc-0.99993 (02 Jan 2011)
+
+ 02 Jan 2011; Hans de Graaff <graaff@gentoo.org> +ruby-odbc-0.99993.ebuild:
+ Version bump.
02 Jan 2011; Hans de Graaff <graaff@gentoo.org> -ruby-odbc-0.9995.ebuild:
Remove old version.
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild
new file mode 100644
index 000000000000..2066e56b534c
--- /dev/null
+++ b/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild,v 1.1 2011/01/02 16:34:56 graaff Exp $
+
+EAPI=2
+
+# ruby19 → fails to build
+# jruby → uses C extensions
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
+HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
+SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-db/unixODBC-2.0.6"
+RDEPEND="${DEPEND}"
+
+# tests require to have an ODBC service enabled, so we can't run them
+# for now :(
+RESTRICT=test
+
+all_ruby_prepare() {
+ # Make sure that it doesn't try to use the absolute-local path for
+ # the extension as we'd be unable to run it properly otherwise.
+ sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
+
+ # Since lib should not get installed avoid it entirely…
+ mv lib contrib || die
+}
+
+each_ruby_configure() {
+ for dir in ext ext/utf8; do
+ ${RUBY} -C${dir} extconf.rb --disable-dlopen || die "extconf (${dir}) failed"
+ done
+}
+
+each_ruby_compile() {
+ for dir in ext ext/utf8; do
+ emake -C${dir} || die "emake (${dir}) failed"
+ done
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ ruby_fakegem_newins ext/odbc.so lib/odbc.so
+ ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
+}
+
+all_ruby_install() {
+ all_fakegem_install
+ dohtml doc/*.html || die
+}