summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-04 15:49:29 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-04 15:49:29 +0000
commit71f8644d6a4b987c76dee5ffd9702dc6fde6b58d (patch)
tree68795b8bc8dea5ea3604bbebf3973beae6e413fe /dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild
parentStable on x86 wrt #69825 (Manifest recommit) (diff)
downloadgentoo-2-71f8644d6a4b987c76dee5ffd9702dc6fde6b58d.tar.gz
gentoo-2-71f8644d6a4b987c76dee5ffd9702dc6fde6b58d.tar.bz2
gentoo-2-71f8644d6a4b987c76dee5ffd9702dc6fde6b58d.zip
Version bumped.
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild
new file mode 100644
index 000000000000..22e2955f7f0f
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.8.3.ebuild,v 1.1 2004/11/04 15:49:29 usata Exp $
+
+inherit ruby
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ruby-ldap/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha ppc ~sparc x86"
+IUSE="ssl"
+USE_RUBY="ruby16 ruby18 ruby19"
+DEPEND=">=net-nds/openldap-2
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ ruby extconf.rb --with-openldap2 || die "extconf.rb failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog README* TODO
+}