summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-04 18:48:35 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-04 18:48:35 +0000
commitb3937f27e8633360bf4ad874502a6a5847bb01f6 (patch)
tree2af263e43595b188597fb271f1152462ed4d113c /dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild
parentForce new enough dssi, so that the destroyed overlays, kde-sunset's version d... (diff)
downloadgentoo-2-b3937f27e8633360bf4ad874502a6a5847bb01f6.tar.gz
gentoo-2-b3937f27e8633360bf4ad874502a6a5847bb01f6.tar.bz2
gentoo-2-b3937f27e8633360bf4ad874502a6a5847bb01f6.zip
Convert to ruby-ng. Fix compilation against >=dev-libs/gsl-1.1.13.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild')
-rw-r--r--dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild b/dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..de6397dbc3b5
--- /dev/null
+++ b/dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gsl/ruby-gsl-0.2.0-r1.ebuild,v 1.1 2010/07/04 18:48:35 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+DESCRIPTION="Ruby wrapper for GNU Scientific Library"
+HOMEPAGE="http://ruby-gsl.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="${DEPEND} sci-libs/gsl"
+RDEPEND="${RDEPEND} sci-libs/gsl"
+
+RUBY_PATCHES=( "${P}-remove-const.patch" )
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+}
+
+each_ruby_install() {
+ DESTDIR="${D}" emake -Cext install || die
+}
+
+all_ruby_install() {
+ dodoc doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins -r contrib samples || die
+}