summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-07-07 18:29:31 +0000
committerPacho Ramos <pacho@gentoo.org>2015-07-07 18:29:31 +0000
commit56a01fc8436e7f46e9b5ab9ab3503dd2538407a9 (patch)
treebc0a41ba288cfe0ca9a905f4c0d8d086dbd0d07a /dev-ruby/ruby-glib2
parentwith approval of alunduil: add slot dependency on dev-lang/Go and drop keepdi... (diff)
downloadgentoo-2-56a01fc8436e7f46e9b5ab9ab3503dd2538407a9.tar.gz
gentoo-2-56a01fc8436e7f46e9b5ab9ab3503dd2538407a9.tar.bz2
gentoo-2-56a01fc8436e7f46e9b5ab9ab3503dd2538407a9.zip
Fix building with glib-2.44 (#554126 by Franz Fellner)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-ruby/ruby-glib2')
-rw-r--r--dev-ruby/ruby-glib2/ChangeLog6
-rw-r--r--dev-ruby/ruby-glib2/files/ruby-glib2-2.2.3-glib-2.44.patch38
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild4
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-ruby/ruby-glib2/ChangeLog b/dev-ruby/ruby-glib2/ChangeLog
index 5813d752fb2f..f945a25c6474 100644
--- a/dev-ruby/ruby-glib2/ChangeLog
+++ b/dev-ruby/ruby-glib2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-glib2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ChangeLog,v 1.119 2015/07/05 10:15:15 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ChangeLog,v 1.120 2015/07/07 18:29:31 pacho Exp $
+
+ 07 Jul 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/ruby-glib2-2.2.3-glib-2.44.patch, ruby-glib2-2.2.3-r1.ebuild:
+ Fix building with glib-2.44 (#554126 by Franz Fellner)
05 Jul 2015; Manuel Rüger <mrueg@gentoo.org> -ruby-glib2-1.2.6.ebuild,
-ruby-glib2-2.0.2.ebuild, -ruby-glib2-2.1.0.ebuild, -ruby-glib2-2.2.0.ebuild,
diff --git a/dev-ruby/ruby-glib2/files/ruby-glib2-2.2.3-glib-2.44.patch b/dev-ruby/ruby-glib2/files/ruby-glib2-2.2.3-glib-2.44.patch
new file mode 100644
index 000000000000..1054bec43395
--- /dev/null
+++ b/dev-ruby/ruby-glib2/files/ruby-glib2-2.2.3-glib-2.44.patch
@@ -0,0 +1,38 @@
+From b2ebc03e04bfac0f60afd1a849958672cb8fe08b Mon Sep 17 00:00:00 2001
+From: Kouhei Sutou <kou@clear-code.com>
+Date: Sat, 4 Apr 2015 15:00:14 +0900
+Subject: [PATCH] glib2: support GLib 2.44
+
+gwin32.h includes an enum type that is available on Windows.
+
+GitHub: fix #361
+
+Reported by Benjamin Maisano. Thanks!!!
+---
+ glib2/ext/glib2/extconf.rb | 10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/glib2/ext/glib2/extconf.rb b/glib2/ext/glib2/extconf.rb
+index d88d971..1c5cd8d 100644
+--- a/glib2/ext/glib2/extconf.rb
++++ b/glib2/ext/glib2/extconf.rb
+@@ -56,10 +56,18 @@
+
+ enum_types_prefix = "glib-enum-types"
+ include_paths = PKGConfig.cflags_only_I("glib-2.0")
++ignore_headers = [
++ "giochannel.h",
++ "gmain.h",
++ "gscanner.h",
++]
++unless (/mingw|cygwin|mswin/ === RUBY_PLATFORM)
++ ignore_headers << "gwin32.h"
++end
+ headers = include_paths.split.inject([]) do |result, path|
+ result + Dir.glob(File.join(path.sub(/^-I/, ""), "glib", "*.h"))
+ end.reject do |file|
+- /g(iochannel|main|scanner)\.h/ =~ file
++ ignore_headers.include?(File.basename(file))
+ end
+ include_paths = PKGConfig.cflags_only_I("gobject-2.0")
+ headers = include_paths.split.inject(headers) do |result, path|
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild
index 68976ffbca38..56f2fc5e9c5b 100644
--- a/dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild
+++ b/dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild,v 1.1 2015/07/05 10:13:04 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ruby-glib2-2.2.3-r1.ebuild,v 1.2 2015/07/07 18:29:31 pacho Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
@@ -16,6 +16,8 @@ DEPEND+=" >=dev-libs/glib-2"
ruby_add_bdepend "dev-ruby/pkg-config
test? ( >=dev-ruby/test-unit-2 )"
+RUBY_PATCHES="${FILESDIR}/${P}-glib-2.44.patch" #554126
+
all_ruby_prepare() {
# Our sandbox always provides LD_PRELOAD in the environment.
sed -i -e 's/unless ENV.empty?/unless (ENV.keys - ["LD_PRELOAD"]).empty?/' test/test_spawn.rb || die