summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 17:51:28 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 17:51:28 +0000
commit85f48288d5193097d27c9503ce612e48497fa6ec (patch)
treeb69c65bfb5f8a3a895b0de09062d71bc14679d34 /dev-ruby/ruby-gettext
parentRevision bump to create stable candidate. (diff)
downloadgentoo-2-85f48288d5193097d27c9503ce612e48497fa6ec.tar.gz
gentoo-2-85f48288d5193097d27c9503ce612e48497fa6ec.tar.bz2
gentoo-2-85f48288d5193097d27c9503ce612e48497fa6ec.zip
Revision bump to create stable candidate.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-gettext')
-rw-r--r--dev-ruby/ruby-gettext/ChangeLog9
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild4
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild58
3 files changed, 68 insertions, 3 deletions
diff --git a/dev-ruby/ruby-gettext/ChangeLog b/dev-ruby/ruby-gettext/ChangeLog
index ab8c257f2803..7956e39dfa0e 100644
--- a/dev-ruby/ruby-gettext/ChangeLog
+++ b/dev-ruby/ruby-gettext/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ruby-gettext
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ChangeLog,v 1.72 2011/01/16 08:53:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ChangeLog,v 1.73 2011/09/28 17:51:28 graaff Exp $
+
+*ruby-gettext-2.1.0_p20100728-r2 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org>
+ ruby-gettext-2.1.0_p20100728-r1.ebuild,
+ +ruby-gettext-2.1.0_p20100728-r2.ebuild:
+ Revision bump to create stable candidate.
16 Jan 2011; Hans de Graaff <graaff@gentoo.org>
-ruby-gettext-1.93.0.ebuild, -ruby-gettext-2.1.0-r1.ebuild:
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild
index 8fe0fb9493ff..07bbda40fd3c 100644
--- a/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild
+++ b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild,v 1.3 2011/01/10 18:08:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r1.ebuild,v 1.4 2011/09/28 17:51:28 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby ree18"
+USE_RUBY="ruby18 jruby ree18"
RUBY_FAKEGEM_NAME="${PN/ruby-/}"
RUBY_FAKEGEM_VERSION="${PV%_*}"
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild
new file mode 100644
index 000000000000..69ac93cf32e7
--- /dev/null
+++ b/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gettext/ruby-gettext-2.1.0_p20100728-r2.ebuild,v 1.1 2011/09/28 17:51:28 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+RUBY_FAKEGEM_VERSION="${PV%_*}"
+
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog ChangeLog-1 NEWS-1 README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby GetText Package is Native Language Support Library and Tools modeled after GNU gettext package"
+HOMEPAGE="http://www.yotabanana.com/hiki/ruby-gettext.html"
+SRC_URI="http://dev.a3li.li/gentoo/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-macos"
+IUSE=""
+SLOT="0"
+LICENSE="Ruby"
+
+ruby_add_rdepend ">=dev-ruby/locale-2.0.5"
+
+RDEPEND="${RDEPEND}
+ sys-devel/gettext"
+DEPEND="${DEPEND}
+ sys-devel/gettext"
+
+ruby_add_bdepend "test? ( || ( virtual/ruby-test-unit dev-ruby/test-unit:2 ) )"
+
+all_ruby_prepare() {
+ # Allison 2.0.3 produces illegal HTML which markaby doesn't like.
+ sed -i '/allison/d' Rakefile || die
+}
+
+each_ruby_test() {
+ # Upstream tries to daisy-chain rake calls but they fail badly
+ # with our setup, so run it manually.
+ pushd test
+ ${RUBY} -S rake test || die "tests failed"
+ popd
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}