summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-18 07:40:35 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-18 07:40:35 +0000
commitb8436fe8d3e47eef77760f1da4c15e3946ed6e7e (patch)
treee027b082312a82dcf82bbf04194e0c7d80bfb4ce /dev-ruby/rspec
parentppc stable wrt #311105 (diff)
downloadgentoo-2-b8436fe8d3e47eef77760f1da4c15e3946ed6e7e.tar.gz
gentoo-2-b8436fe8d3e47eef77760f1da4c15e3946ed6e7e.tar.bz2
gentoo-2-b8436fe8d3e47eef77760f1da4c15e3946ed6e7e.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog7
-rw-r--r--dev-ruby/rspec/rspec-1.3.2.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index e47b4c71de2f..7489c7014b39 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.99 2011/07/18 07:34:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.100 2011/07/18 07:40:35 graaff Exp $
+
+*rspec-1.3.2 (18 Jul 2011)
+
+ 18 Jul 2011; Hans de Graaff <graaff@gentoo.org> +rspec-1.3.2.ebuild:
+ Version bump.
18 Jul 2011; Hans de Graaff <graaff@gentoo.org> rspec-2.6.0.ebuild:
Depend on any of the 2.x versions, not the one with the same minor version.
diff --git a/dev-ruby/rspec/rspec-1.3.2.ebuild b/dev-ruby/rspec/rspec-1.3.2.ebuild
new file mode 100644
index 000000000000..6b17e1c3b7a0
--- /dev/null
+++ b/dev-ruby/rspec/rspec-1.3.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2.ebuild,v 1.1 2011/07/18 07:40:35 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
+
+RUBY_FAKEGEM_BINWRAP="spec"
+
+RUBY_FAKEGEM_GEMSPEC="rspec.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# it's actually optional, but tests fail if it's not installed and
+# some other package might fail tests, so require it anyway.
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+RDEPEND="!<dev-ruby/rspec-rails-${PV}"
+
+# don't require test dependencies for jruby since we cannot run them
+# for now (fakefs doesn't work).
+#
+# We should add nokogiri here to make sure that we test as much as
+# possible, but since it's yet unported to 1.9 and the nokogiri-due
+# tests fail for sure, we'll be waiting on it.
+USE_RUBY="ruby18 ree18 ruby19" \
+ ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.0.0
+ dev-ruby/zentest
+ >=dev-ruby/syntax-1.0
+ >=dev-ruby/fakefs-0.2.1 )"
+
+# the testsuite skips over heckle for Ruby 1.9 so we only request it for 1.8
+USE_RUBY="ruby18 ree18" \
+ ruby_add_bdepend "test? ( >=dev-ruby/heckle-1.4.3 )"
+
+all_ruby_prepare() {
+ # Replace reference to /tmp to our temporary directory to avoid
+ # sandbox-related failure.
+ sed -i \
+ -e "s:/tmp:${T}:" \
+ spec/spec/runner/command_line_spec.rb || die
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Tests for JRuby are disabled because dev-ruby/fakefs does not currently support"
+ ewarn "JRuby properly and it's needed to run the tests."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}