summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-19 09:26:14 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-19 09:26:14 +0000
commitd176f4107548247e3a0ceeac042199bc93f940a2 (patch)
treecc66fe7976e4e3909465b75939bfe9fe0c6790a2 /dev-ruby/rspec-mocks
parentVersion bump. (diff)
downloadgentoo-2-d176f4107548247e3a0ceeac042199bc93f940a2.tar.gz
gentoo-2-d176f4107548247e3a0ceeac042199bc93f940a2.tar.bz2
gentoo-2-d176f4107548247e3a0ceeac042199bc93f940a2.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog7
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.5.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index ed9e33867132..79210740d76c 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.7 2011/02/02 14:13:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.8 2011/02/19 09:26:14 graaff Exp $
+
+*rspec-mocks-2.5.0 (19 Feb 2011)
+
+ 19 Feb 2011; Hans de Graaff <graaff@gentoo.org> +rspec-mocks-2.5.0.ebuild:
+ Version bump.
02 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org>
rspec-mocks-2.4.0.ebuild, +files/rspec-mocks-2.4.0-no-cucumber.patch:
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.5.0.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.5.0.ebuild
new file mode 100644
index 000000000000..11ddde3c3b90
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.5.0.ebuild,v 1.1 2011/02/19 09:26:14 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# cucumber and rspec-core are loaded unconditionally in the Rakefile,
+# so we also need to require them for USE=doc.
+ruby_add_bdepend "test? (
+ dev-ruby/rspec-core:2
+ dev-ruby/rspec-expectations:2
+ )
+ doc? ( dev-ruby/rspec-core:2 )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ RUBYLIB="${S}/lib" rake rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
+
+ # There are features but they require aruba which we don't have yet.
+}