summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-02-13 21:20:31 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-02-13 21:20:31 +0000
commitb71507437e84dd2a5f216fbaf1e113066bcf8502 (patch)
tree922889f0ccf840cd5bdbba044fd37e35ad2d3b34 /dev-ruby/rspec-expectations
parentUpdate ebuild to EAPI 5. Specify LICENSE more precisely. (diff)
downloadgentoo-2-b71507437e84dd2a5f216fbaf1e113066bcf8502.tar.gz
gentoo-2-b71507437e84dd2a5f216fbaf1e113066bcf8502.tar.bz2
gentoo-2-b71507437e84dd2a5f216fbaf1e113066bcf8502.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rspec-expectations')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog10
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
index 934514983b77..10f72b12a73a 100644
--- a/dev-ruby/rspec-expectations/ChangeLog
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-expectations
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.58 2013/12/26 15:06:52 maekke Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.59 2014/02/13 21:20:31 mrueg Exp $
+
+*rspec-expectations-2.14.5 (13 Feb 2014)
+
+ 13 Feb 2014; Manuel Rüger <mrueg@gentoo.org>
+ +rspec-expectations-2.14.5.ebuild:
+ Version bump.
26 Dec 2013; Markus Meier <maekke@gentoo.org>
rspec-expectations-2.12.1.ebuild:
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild
new file mode 100644
index 000000000000..a4c05da376cc
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.14.5.ebuild,v 1.1 2014/02/13 21:20:31 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.3"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rspec-core-2.11.0:2
+ >=dev-ruby/rspec-mocks-2.14.0:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+
+ # fix up the gemspecs
+ sed -i \
+ -e '/git ls/d' \
+ -e '/add_development_dependency/d' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+}